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About the X4 BPMS

Digitalization requires a holistic approach, which presupposes that also the used solution has to 
reflect that. X4 BPMS supports you as a central platform in solving these challenges. The focus is on 
modeling, implementing and monitoring your business processes. Therefore, the X4 BPMS contains 
all necessary tools and is compatible with a variety of interfaces and formats. That helps to avoid 
isolated information silos and media breaks that inhibit productivity, and accelerate digitization at the 
same time.

Implementing business processes without programming effort enables a large number of users to 
enter into the management of business processes. That's important, since employees of the 
specialist department usually know best what is important in the respective business 
processes. Therefore, you should rely on the X4 BPMS as a platform whose tools reduce complexity to 
such an extent that business processes can be analyzed, optimized, modeled, as well as controlled 
and documented even without programming knowledge. All tools support integrated, graphical 
process modeling and implementation and generate processes that are executed by the X4 BPMS 
with high performance.

X4 Designer: Modelling processes and rules graphically
X4 Server: Simulating and executing processes and rules
X4 Adapter: Integrating third-party systems into processes
X4 Activities: Providing web apps for employees and customers

Target audience of this documentation
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This document is intended for all users who want to capture, model and optimize their business 
processes with the X4 BPMS. With its modelling tool, X4 Designer, the X4 BPMS offers the 
internationally established standard BPMN 2.0 (Business Process Model and Notation). Moreover, the 
documentation explains the basic principles of modeling business processes with the X4 BPMS and 
how to use the X4 Designer and its various tools.
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1 Interface

1 Menu bar The menu bar allows to open various functions and editors of the 
X4 Designer.

2 Toolbar The toolbar offers different functions and display options. Some 
symbols are only active, if the corresponding function is 
available for the selected or opened element, see also Toolbar.

3 Views Views can be arranged individually via drag-and-drop.
4 Perspectives Switch between X4 Designer and BPMN Designer perspective.

5 Editors and workspace Processes and files are opened here for editing in tabs.
6 Status bar The status bar displays the connected server, the logged-in user 

and the version.

1.1 Toolbar
Various functions and display options can be called up via the toolbar. Some icons are only active if 
the relevant function is available for the selected or opened element.
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Connect Connect to the server

Disconnect Disconnect from the server

New Add new element

 The insert option varies depending on where you are in the 
tree structure in the Repository Navigator.

Save Save changes in the currently opened window

Save all Save all changes

Repository Refresh Perform server-side update

/
Attach/Detach Debug Attach debugger to server instance / Detach debugger from 

server instance

Start Debugging Start Debugger

Undo Undo last editing step

Redo Restore undone step

Cut Cut selection

Copy Copy selection

Paste Paste selection

Start Debugging Call up options for process execution

Start Debugging: debug process (show and fix errors)
Start Without Debugging: Execute process directly
Debug/Run Options: Open Run/Debug settings in X4 
Designer

Suspend Stop debugging process

Resume Continue debugging process

Stop Debugging Terminate debugging
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Step Into Execute process step (display steps of the subprocess)

Step Over Execute process step (without displaying steps of the 
subprocess)

Step Return Jump out of subprocess

Toggle Breakpoint Set or remove breakpoint for marked element

Clear all Breakpoints Delete all breakpoints in this process

Quick Watch Open Quick Watch view to view placeholders, dynamic 
parameters and context variables with their values during 
debugging.

Output Open Output view to view the result of each process step during 
debugging.

Zoom Out Zoom out view

Zoom Select zoom level

Zoom In Zoom view

Snap to grid Display grid and align elements to grid

Show Process Quality Index Display Process Quality Index

1.2 Context Menu
Context menu for process components

When you right-click a process component in the X4 Designer's editor area, you have access to 
different features – depending on the component type and the:
Add Component Add new process component
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 Layout Align selected process components

Align Horizontal: Align the process components 
horizontally
Align Vertical: Align the process components vertically
Distribute Horizontal: Distribute the process components 
horizontally
Distribute Vertical: Distribute the process components 
vertically

Select All Select all process components
Copy Process Diagram to 
Clipboard

Copy the process diagram

Edit Label... Edit the process component's label
Undo ... Undo the last editor action

Redo ... Redo a previously undone editor action

Copy Copy a selected process action

Cut Cut selected process action

Set ... document Replace a marked process component with another repository 
element

Edit ... Edit a selected process component (module components and 
documents only)

Toggle Breakpoint Set a debug breakpoint for the selected process action

Delete Delete a selected process component from the process diagram

Validate Check the subprocess' validity (subprocesses only)
Preview Open process component in a separate editor tab (Module 

components and documents only)

Show input schema Display input schema assigned to the sub-process, if available
Show output schema Display output schema assigned to the sub-process, if available
Select in Repository 
Navigator

Show process component in the Repository Navigator

View Call Hierarchy Display the processes using the selected process component

Refresh Reload a selected process component from the repository (Module 
components and documents only)

Bring to Front Bring a selected symbol to the foreground of the diagram
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Bring Forward Bring a selected symbol one level up towards foreground

Send Backward Bring a selected symbol one level down towards background

Send to Back Bring a selected symbol to the background of the diagram

Properties Display process component properties in the Properties view

Schema Declaration ... Specify schema declaration for the process

Context menu in the Projects view

You can open the context menu by right-clicking on an element within the Projects view.

New Create new elements (processes, directories, adapters, etc.) in the 
repository

Open / Open with Open the selected element (process, folder, adapter etc.) with the 
default editor or a specific editor

Save As Template Saves the selected element as template

Copy full path to 
Clipboard undCopy XStore 
URL to Clipboard

Copy the path of the selected element to the clipboard (as relative 
folder path or as xstore:// URL)

Cut, Copy and Paste Cut, copy, or pastes the selected element(s)

Delete Delete selected element from the repository (irreversible)
Refactor/Rename Rename an element (and change references, if desired)
Exclude from Project Exclude the resource from the project

Include to Project Include an excluded resource to the project

Repair References Repair incorrect repository resource paths in process diagrams
Validate Check the selected process's validity
View Call Hierarchy Display the processes that use the selected elements
Start Without Debugging Run process directly
Import Import resource to the repository
Export Export project or resource
Clean-Up Project Select and delete unused files from the repository

•

•

The file will remain in the file system, but is no longer part 
of the project and is grayed out.
The usual operations such as opening, editing, copying, 
deleting, etc. of excluded files are disabled.
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1.3 Perspectives
A perspective is a defined arrangement of views and the editor area. The arrangement of the views 
can be defined by drag-and-drop.

X4 Designer The X4 Designer perspective is the default perspective.

Debug The Debug perspective is an optimized perspective to debug business and technical 
processes.

BPMN 
Designer

The BPMN Designer perspective is an optimized perspective to model business 
processes.

1.3.1 Switching perspectives
In X4 Designer, you can switch between perspectives. The arrangement of the views is kept.

To change the perspective, click on the icon of the desired perspective in the upper right 
corner.

1.3.2 Reseting perspectives

To reset a perspective, switch to the perspective.
Select Window > Reset Window Layout in the menu bar.

1.4 Views
Projects The Projects view displays a tree structure of the connected repository with various 

elements such as projects, folders and files. The context menu can be opened by 
right-clicking on an element in the Projects view. The available options change 
depending on where in the tree structure the context menu is called.

The Filter text field above the project tree can be used to search for files within the 
connected repository. Placeholder like * or ? are not possible.

The following actions can be performed using various buttons:

 Jump from active Editor to Repository Navigator: Highlight opened file in the 
editor within the Repository Navigator.

 Show or hide all files: Show and hide contents of the file system. Files 
excluded from the project are grayed out.

Apps The Apps view displays all X4 Apps that are used to bundle projects.
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Properties In the Properties view, the properties of selected process modules and of opened 
processes can be displayed and edited:

The left column displays the property name, the right column contains 
the corresponding values.
A title and a description can be stored for each process. These are displayed in 
the generated documentation.
To edit properties of an opened process, click on an empty area on the workplace.

The most common properties are displayed by default, however, additional settings 
can be made using the Properties view toolbar:

 Pin to Selection: Pin displayed properties in the Properties view

 Show Categories: Show properties sorted by categories

 Show Advanced Properties: Show advanced properties

  Restore Default Value: Restore to default value

View Menu: Open additional options

Run/Debug 
Console

If a process is checked for errors or simulated, debug information is displayed in the 
Run/Debug Console view for each executed process step. Error messages are 
highlighted in red, successful status messages are green.

When a process step outputs an intermediate result, it is stored in a temporary file 
during debugging, which you can view using the corresponding reference (e. g. file:
//1376054979039/). 

The Run/Debug Console view can be accessed from the View > Run/Debug 
Console menu.

file://1376054979039/
file://1376054979039/
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Output The Output view allows to view the intermediate results of each debug step.

The following additional actions can be performed via the toolbar:

Find content: Find data in the Output view

Copy all content: Copy all data from the Output view to the clipboard
Copy selected content: Copy selected data from the Output view to the 

clipboard

 Save content of output view: Save the data form the output view

 Format the content of the output view: Format the data form the output view

The Output view can be opened during debugging via the menu Debug > Output or 
using the Output icon  in the toolbar.

If the result of the debug step contains content greater than 1 MB, a warning 
is displayed and the result can be downloaded via a button.
Large amounts of data can affect the performance of the X4 Designer. 





X4 BPM

© SoftProject GmbH 18

X4 Server 
Log

The X4 server log view allows to track the server status and especially errors in the 
X4 Server log from within the X4 Designer.

 The Server Log view can be accessed via the View > X4 Server Log menu.

Call 
Hierarchy

The Call Hierarchy view allows to display all repository elements using a certain 
process or process component in the repository.

Right-click on the desired element in the Repository Navigator to bring up a context 
menu. View Call Hierarchy then displays a list of all repository items that contain at 
least one reference to the selected item.
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Error Log The Error Log view allows to view errors that occurred in the X4 Designer.

The following additional actions can be performed via the toolbar:

 Export Log: Export Error Log and save it as .log file
 Import Log: Import Error Log (.log)
 Clear Log Viewer: Clear Error Log 
 Delete Log: Delete Error Log permanently
 Open Log: Open log file (.log) in X4 Designer
 Restore Log: Restore Error Log
View Menu: Open additional options

 The Error Log can be opened via the menu View > Error Log.

Problems In the Problems view, all errors and warnings are listed. The filter can be used to 
customize the displayed list.

Debug 
sessions

The Debug sessions view lists all active debug sessions. In the Debug sessions view, 
double-click the desired process to switch to the debug session.

Active debug sessions are marked in gray. New debug sessions connected to the 
server are highlighted in orange.

Breakpoint
s

In the Breakpoints view, all set breakpoints are listed. In the Breakpoints view, 
breakpoints can be activated, deactivated and deleted. Additionally, all breakpoints 
can be skipped without deleting the breakpoints.
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Quick 
Watch

In the Quick Watch view, placeholders, dynamic parameters and context variables 
can be viewed with their values during debugging.

Selected variables are updated after each debug step.

The Quick Watch view can be accessed during debugging via the Debug > Quick 
Watch menu or via the Quick Watch icon in the toolbar.

Outline In the Outline view, the complete process diagram is displayed as an image. By 
clicking on the individual areas of the illustration, it is easy to navigate through the 
process, even if it is larger than the size of the Designer window.

 The Outline view can be opened via the menu View > Outline.

Base64 Base64 encode or decode strings

Digest Generate hash value for strings

Regex Apply regular expression (Regex) to a string to test the expression or to directly 
replace the string according to a pattern

URLCodec URL encode or decode strings

1.4.1 Open views

Select the desired view from the View menu in the menu bar.

If the result of the debug step contains content greater than 1 MB, a warning 
is displayed and the result can be downloaded via a button. 
Large amounts of data can affect the performance of the X4 Designer. 



No other views can be opened in the BPMN Designer perspective, all relevant views are open 
by default.
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1.5 Editors
In X4 Designer, processes and files are opened in tabs for viewing and editing. The used editor 
depends on the opened file type.

Editor Usage Description
BPMN Editor .bpm

.pld

With the BPMN Editor you can model business 
processes according to the notation standard BPMN 
2.0.

Process Editor .wrf With the Process Editor you can graphically model 
Technical Processes.

Mapping Editor .xsl

.rep

With the Mapping Editor you can create and edit 
XSL mappings in a graphical view.

XML Editor .xml

.xhtml

With the XML Editor you can create and edit well-
formed XML documents.

XSD Editor .xsd

JSON Editor .json With the JSON Editor you can edit JSON documents 
directly in the X4 Designer.

Database Editor .stm With the Database Editor you can define SQL 
queries for database connection modules to 
retrieve data from a relational database.

1.5.1 BPMN Editor
The BPMN Editor allows you to model Business Processes in compliance to the notation standard 
BPMN 2.0. The editor is similar to the Process Editor within X4 Designer regarding layout and 
functionality, but differs regarding the process components and symbols in the process diagram.
The BPMN Editor allows you to link your modeled Business Processes directly to Technical Processes. 
Without switching the development environment, you can model your Business Processes and 
Technical Processes, and test and execute them on the X4 Server.

Since BPMN processes can contain non-automatable actions, e. g. human workflows, BPMN 
processes aren't necessarily executable by the X4 Server. BPMN processes may contain technical 
processes as subprocess tasks, and can be executed.

The free-flow mode additionally allows to use the BPMN Editor as plain BPMN drawing tool 
with an extended BPMN palette where the run/debug functionality is disabled.
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1.5.2 Database Editor
The Database Editor allows to define SQL queries for database connection components in order to 
retrieve data from a relational database. The logical separation of the process components SQL 
statement and database connection allows these components to be used flexibly and multiple times 
within the X4 Designer.

The Database Editor's structure

The Database Editor provides two different tools:

Statement Editor: Allows to connect to a database and displays the structure of the connected 
database. This structure can be used to create an SQL statement for the database. 
Mapping Editor: Allows to define a mapping for elements of an input XML document to the 
named parameters of the statement previously created with the Statement Editor. This 
mapping is subsequently used to create an XSL mapping, which generates a dynamically 
created input for the JDBC Connector using a suitable input XML document.

1.5.2.1 Statement Editor

The Statement Editor is divided into the following areas:

To open the Database Editor create a new SQL statement file (.stm) or open an already 
existing SQL statement file.
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Connecti
on area

Within this area a connection to a database can be established by means of a JDBC 
Connector. 

JDBC Connector: xstore URL to a JDBC Connector

Connect: Connect to the database
 The connection status is displayed under Status. 

Execute Statement: Execute sql statement

Databas
e area

The database's structure is displayed here after establishing the connection. The 
following icons are used to visualize the structure:

 Database schema
 Database table
 Primary key
 Primary key/ Foreign key
 Foreign key
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•
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•

•

•

•

•

•

•

•

•

•

•

Stateme
nt area

Here, different statements can be created for the connected database via the context 
menu:

New Named Prepared Statement: Create a new Named Prepared Statement 
in Statements Root
Edit Named Prepared Statement: Edit Named Prepared Statement
New RowSet: Create new RowSet.

 Only one RowSet can exist within a Named Prepared Statements. It is generated 
automatically when creating the Named Prepared Statement.
A new RowSet can only be created, if the existing one has been deleted.

New Row: Add a new row within a RowSet

New Named Parameter Value: Add a new Named Paramerter value within a row

Edit Named Parameter: Edit Named Parameter

New SELECT Statement: Create new SELECT statement

Edit SELECT: Edit SELECT instruction

Edit FROM: Edit FROM within a SELECT statement

New INSERT Statement: Create new INSERT statement

Edit INTO: Edit INTO instruction

New VALUE Entry: Create new VALUE entry

Edit VALUE: Edit VALUE 

New UPDATE Statement: Create new UPDATE statement

Edit UPDATE: Edit UPDATE instruction

New SET Entry: Create new SET entry

Edit SET Entry: Edit SET entry

New DELETE Statement: Create new DELETE statement

Edit FROM: Edit FROM instruction

Edit WHERE: Edit WHERE condition  

New Column: Add new column within an INSERT or SELECT instruction

New Table: Insert new table within an UPDATE or SELECT instruction

Delete: Delete element

Drag&Drop actions

The following Drag&Drop actions can be performed within the Statement area:

For further information on how to create and edit statements, see section Statem
ent für eine verbundene Datenbank erstellen.
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SQL 
statement

Database 
element

Statement 
element

Action

SELECT Column SELECT Add the column to be selected.
 If the table corresponding to the 

added column is not already entered 
within FROM, it will be entered 
automatically.

Table FROM Add the table from which is to be 
selected.

UPDATE Column SET Entry Set the column as entry.
 If the table corresponding to the 

added column is not already entered 
within UPDATE, it will be entered 
automatically.

Table UPDATE Set the table to be updated.
INSERT Table INTO Set the table into which is to be 

written.
 If there is already a table, it will be 

replaced. Already set columns will be 
deleted thereby.

Column INTO Set the column into which is to be 
written.

 This is only possible, if the column 
originates from the set table.

DELETE Table FROM Set the table to be deleted.
 If there is already a table, it will be 

replaced.

1.5.2.2 Mapping Editor

The Mapping Editor allows to define a mapping for elements of an input XML document to the named 
parameters of the statement previously created with the Statement Editor. This mapping is 
subsequently used to create an XSL mapping, which generates a dynamically created input for the 
JDBC Connector using a suitable input XML document.

The Mapping Editor is divided into the following areas:
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Source area The Source area is on the Mapping Editor's left side. The input XML 
file can be displayed here and assigned by drag & drop.

The context menu provides the following options:

Collapse: Collapse a node's child nodes
Expand: Expand the child nodes of the selected node
Remove Input: Remove assigned input XML document

Linking area The Linking area is located in the Mapping Editor's middle column. 
It visualizes the xsl:value-of connections between an element 
in the source document and a Named Parameter in the statement 
as line.

Statements area The Statements area is located on the Mapping Editor's right side. 
The complete structure of the statement file is displayed here. 
Moreover, elements of an input XML file can be mapped to the 
child elements of a Row element.

1.5.3 JSON Editor
The JSON Editor allows JSON documents to be edited directly within the X4 Designer. 

The Outline view displays the structure of the opened JSON document. Moreover, you can also use 
the context menu Quick Outline or the key combination CTRL+O to open the Quick Outline view and to 
search for keys and values within the JSON document.

Shortcuts

CTRL+O Open the Quick Outline view

To open the JSON Editor either create a new  JSON Document or open an already existing 
document. 
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CTRL+Shift+F Format the JSON code

1.5.4 Mapping Editor
The Mapping Editor allows to create and edit XSL mappings in a graphical interface. Using XSLT you 
can transform an XML data structure into another XML data structure or into an XSL-FO document. 
The Mapping Editor supports you with a graphical interface and with an automatic stylesheet and 
XPath validation when creating or editing XSL mappings.

An XSL mapping involves three documents:

XML source document (or an XML schema to provide the input structure)
XSLT stylesheet (created with the Mapping Editor)
Result document (in most cases: XML)

The Mapping Editor's structure

The Mapping Editor is divided into the following areas:

The formatting of the JSON code and the colors for syntax highlighting can be changed under 
Tools > Options > JSON Editor, see also  Configuring the JSON Editor.



To open the Mapping Editor, create a new mapping or open an already existing XSL mapping.
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1 Source pane The source document to be transformed or an XML Schema file (.
xsd) is displayed here.

Using the context menu you can edit selected nodes as follows:

Copy XPath for this element to Clipboard: Copy XPath 
expression of the selected element to the clipboard and 
use it elsewhere
Assign Input: Assign input XML document
Remove Input: Remove assigned input XML document

2 Linking pane The Linking pane displays lines that visualize the relationships 
between source and stylesheet nodes.

The chapter Tastenkombinationen im Mapping 
Editor gives you an overview of the most important key 
combinations helping you to work with XSL stylesheets.
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3 Stylesheet pane The Stylesheet pane is where you edit the stylesheet. It displays 
the XSL stylesheet in an editable tree with specialized features 
for editing XSLT stylesheets. 

The different parts of the styleheet are displayed with symbols 
and collored highlightings in the tree view:

Nodes that contain XSLT instructions are colored brown and 
have a corresponding icon e. g. 

If a node contains an XPath expression, it is indicated by the 
XPath icon    on the left side. You can click on this icon to 
edit the XPath expression.

Virtual nodes (incurred nodes from an assigned XML 
document or XML schema that do not yet explicitly exist in 
the XSLT stylesheet) are greyed out.

Using the context menu in the stylesheet pane you can edit 
selected nodes as follows:

Edit XSL Element: Edit selected XSL element
Rename: Rename the node
Element: Insert an element
Attribute: Insert attribute
Edit: (In case of processing instructions and namespace 
declarations) Edit node content
XSL Element: Insert XSL element

as Child: as child node
Before: as node before the selected node
After: as node after the selected node

Add other nodes: Add other nodes (Namespace, Text, Comme
nt, Processing Instruction) 
Add here: (In case of virtual nodes) Convert a virtual node into 
a real node
Add X4 Processing Instructions: Insert X4-specific 
processing instructions to set Dynamic Parameters.

Condition State for status information
Log Info for log messages
Dynamic Parameter to set dynamic values
No Result for empty mapping outputs

Add X4 Placeholder: Insert X4-specific placeholders
Add Parent: Insert a parent element (superordinate element)
Cut/Copy/Paste: Cut, copy, or paste selection 
Delete: Delete the selected node
Expand/Collapse: Expand or collapse the child nodes of the 
selected node
Assign Virtual Nodes: Insert virtual nodes from an XML 
document or schema
Remove Virtual Node: Delete virtual nodes from an XML 
document or schema



X4 BPM

© SoftProject GmbH 30

•

•

•

•

4 Source and Design view You can switch between two different views within the Mapping 
Editor:

Design : The editor displays the XSLT stylesheet as a 
tree in a three column view. Here you can graphically map 
nodes of the source document/schema to the XSLT 
stylesheet nodes by drawing connection lines.

Source : In this source code view you can edit the XSLT 
stylesheet directly in an XML editor

5 Output The result of locally run XSL mappings is displayed in the Output 
view.

The following additional actions can be performed via the 
toolbar:

 Save content of output view: Save the data form the 
output view

 Format the content of the output view: Format the data 
form the output view

6 Run transformation Via Run Transformation you can run the XSL mapping locally 
and display the transformation result in the output view (5).

1.5.4.1 Keyboard shortcuts within the Mapping Editor

Useful shortcuts for working with XSL stylesheets within the graphical view of Mapping Editor

Drag&Drop Actions

The XSL Element Creation Wizard allows to create XSL 
mappings quickly and easily. The wizard offers the 
complete range of XSLT 2.0 elements and enables to 
create them easily via the context menu.

Within the wizard, you can specify whether the new 
element is to be created before, after or as a child of the 
selected element. Features like auto-completion, or the 
display of all available and allowed XSL elements enable 
faster work.

 

Moreover, the wizard allows to set and to edit the 
attributes of the XSL element. Required attributes are 
set automatically, optional attributes can be selected 
and filled as needed. 
For attributes that have multiple options to choose 
from, a drop-down list with all available values is 
provided.



Moreover, the wizard allows to set and to edit the 
attributes of the XSL element. Required attributes are 
set automatically, optional attributes can be selected 
and filled as needed. 
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Reference a value to a target node 
using xsl:value-of

Drag a node from the source document to the target node

Reference multiple values into a 
target node using xsl:value-of

Keep the Alt key pressed and drag all desired nodes from the 
source document to the target node

Result: An xsl:value-of element will be created whose select
attribute contains all referenced nodes. In a next step, this list of 
nodes can be correlated by using an XPath function like concat(
)or logical operators.

Example: <xsl:value-of select="Element1Element2">

Copy a node using xsl:copy-of Keep the Ctrl key pressed, and drag a node from the source 
document to the target node

Create a for-each loop for a node 
using xsl:for-each

Keep the Shift key pressed, and drag a node from the source 
document to the target node

Function Shortcut
Basic functions Edit element Enter

Run XSL transformation F9

Insert element Ins

Insert attribute Alt+Ins

Insert text Ctrl+Ins

Insert surrounding parent element Ctrl+Shift+Ins

Rename a element Alt+Shift+R

Remove selected node Del

Format/indent the code (in Source view) Ctrl+Shift+F

Copying nodes Insert selected node as preceding sibling Ctrl+ Alt+Up

Insert selected node as following sibling Ctrl+ Alt+Down

Insert selected node as preceding parent Ctrl+Alt+Left

Moving nodes Move selected node up Alt+Up

Move selected node down Alt+Down

Move to parent element (pull up) Alt+Shift+Left

Navigating trough the 
stylesheet tree

Go to parent node Ctrl+Shift+Left

Go to next node Ctrl+Shift+Down
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Go to previous node Ctrl+Shift+Up

Select connected nodes in the source pane and 
stylesheet pane

Shift+Ins

Restore last selection Alt+Shift+Down

1.5.5 Process Editor
With the Process Editor, Technical Processes can be modeled graphically. For each Technical 
Process and for the individual process modules, you can also define how they should be executed.

With the Process Editor you can:

establish connections between different back-end systems,
transform data in real time,
implement business rules in the modeled process and
debug modeled processes and execute them on the X4 server.

1.5.5.1 Process Quality Index

The Process Quality Index is a graphical tool that indicates how well an ESB process has been 
modeled in terms of standards compliance and clarity.

Rating of the criteria

Criteria Condition Rating
Number of elements 100% →  < 15 elements

 75% → < 20 elements

 50% → < 25 elements

 25% → < 30 elements

   0% → >= 30 elements

45%

The Process Quality Index is an experimental feature. The functionality is currently still 
limited and is being developed continuously.
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Criteria Condition Rating
Number of stop elements 100% → < 3 elements

 75% → < 4 elements

 50% → < 5 elements

 25% → < 6 elements

   0% → >= 6 elements

15%

Labels of the elements are not empty true → 100%

false → 0%

10%

Process title was set (not the name of process 
file)

true → 100%

false → 0%

5%

Labels of the elements were adjusted (not 
filename)

true → 100%

false → 0%

5%

No elements on the right side of stop elements true → 100%

false → 0%

5%

No elements on the left side of start elements true → 100%

false → 0%

5%

No overlapping elements true → 100%

false → 0%

5%

Flow Direction Index 5%
Maximum 100%

1.5.5.2 Keyboard shortcuts within the Process Editor

All shortcuts of the Process Editor in an overview.
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Function Shortcut or action
Running and 
debugging 
processes

Execute process F9

Debug process (and eventually abort active 
debug session)

F4

Execute and show a single process action 
(also in subprocesses) while debugging

F5

Execute a process action (without showing 
subprocess actions) while debugging

F6

Jump back from the subprocess to the 
main process while debugging

F7

Pause debugging Ctrl + F8

Resume paused debugging F8

Cancel debugging Ctrl + F2

Inserting 
process 
components and 
transitions

Insert process component from the 
repository between two connected 
components

Insert a file from the repository onto 
the transition via drag&drop; When 
the line expands, drop the symbol.

Move process component while keeping the 
transition

Press Alt while moving the process 
component on the workplace.

Delete process component while keeping 
the transition

Alt + Del.

Replace process component by another 
repository file

Drag and drop a repository file on the 
process component to be replaced.

Insert process component behind an 
unconnected component, and automatically 
create a transition

Select the unconnected process 
component, press Shift, and drag 
the repository file behind the 
selected process component.

Editing 
elements

Select all workplace elements Strg+A

Cut out process component Strg+X

Copy process component Strg+C

Paste process component Strg+V

Delete process component Del

Undo last action Ctrl+Z

Redo last action Ctrl+Y

Edit process component Double-click the symbol
Close editor Ctrl+W

Save modified element Ctrl+S
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Rename repository file F2

Move repository file Move the file into the target folder 
via drag&drop

Reload F5

Changing views Zoom out of the process diagram Ctrl+- 

Zoom into the process diagram Ctrl++ 

1.5.6 XML Editor
Using the XML Editor you can create and edit well-formed XML documents.

The XML Editor's structure

There are two views available for the processig of XML documents, the Design view and the Source
view. You can switch between these to views by using the tabs at the Editor's lower edge. 

To open the XML Editor create a new XML file or open an already existing file.
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Design view The Design view displays the tree structure of the opened XML 
document as a table. In the left column, you find the different nodes, 
which can be expanded, if child nodes exist. In the right column, the 
node values are displayed.

The context menu provides the following functions:

Remove: Remove selected node
Add DTD Information: Add a DTD (Document Type Definition) 
structure information
Edit Namespaces: Edit the node's namespaces
Add Attribute: Add new XML attribute
Add Child: Add child node (element, processing instruction 
etc.)
Add Before: Add node before the selected node
Add After: Add node behind the selected node

Source view In the XML Editor's Source view you can edit the XML document's 
source code. The editor supports you with the following functions:

Syntax highlighting: Different node types are hinghlighted with 
colors.
Check well-formed: XML documents are checked, if they are well-
formed when saving.
Syntax completion: The editor suggests elements when you want 
to insert new nodes
Pretty-Print: Format the XML documents with indents and line 
breaks to be more readable via the menu Source > Format.
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2 BPMN Process components and their use
At the right edge of the drawing area there is a toolbar, the palette. It contains process module 
symbols that you can drag and drop into the drawing area.
Available process components for modeling Business Processes (.bpm)

2.1 Events
When creating a new Business Process, a start and an end event are already inserted into the process 
diagram by default. In addition, further event elements can be dragged from the palette into the 
process diagram and used during process modeling. The available elements are explained in more 
detail below.

2.1.1 Start

 Start: Defines a Business Process's start event according to BPMN 2.0, and allows 
differentiating between various event types.

Properties

Case Management
Case State Case state to be set with this element

Possible values: Any already defined case state value; You can manage 
available case states by clicking , see Managing Case States.

Technical
Label Label of the symbol within the process diagram

Event Event type
Possible values:

None Start: General start event (Default)

Error Start: Start event in case of an error

Message Start: Message-based start event

Multiple Start: Multiple start event

Conditional Start: Start event based on a business rule

Signal Start: Start event that follows a signal

Timer Start: Time-triggered start event

Escalation Start: Start event based on an escalation
Compensation Start : Start event based on a compensation
Parallel Multiple Start : Multiple parallel start event
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Setting case states using Start Events

Start Events allow you to set a case state while executing the Business Process. The property Case 
Management > Case State configures all case states that are available throughout the Business 
Process. To set a case state, perform the following steps:

Select the start element, and switch to the Properties view.
Select in property Case Management > Case State a predefined case state, e.g. IN 
PROGRESS.

When executing the Business Process, the case state will now be updated. The case state 
change is indicated by a corresponding label for the event.

2.1.2 Intermediate

 Intermediate: Defines an intermediate event of a Business Process according to BPMN 2.0 
and allows to set a case state using the property Case State, see Managing Case States.

Properties

Case Management
Case State Case state to be set with this element

Possible values: Any already defined case state value; You can manage available 
case states by clicking , see Managing Case States.

Technical
Document Path to the corresponding process within the X4 Repository

Label Label of the symbol within the process diagram

If the property Case State doesn't provide an option yet, no case state has been 
defined for the business process. To manage case states, click property Case 
State and open the case state management by clicking the

button, see Managing Case States.



As an alternative, the case state can also be set dynamically using Technical Processes.
The Case Management adapter is provided for this purpose.
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1.
2.
3.

Event Event type
Possible values:

None Intermediate: General intermediate event (Default)

Message Intermediate (Catch): Incoming message intermediate event
Message Intermediate (Throw): Outgoing message intermediate event

Cancel Intermediate: Cancel intermediate event

Compensation Intermediate (Catch): Incoming compensation 
intermediate event

Compensation Intermediate (Throw): Outgoing compensation 
intermediate event

Error Intermediate: Error intermediate event
Escalation Intermediate (Catch): Incoming escalation intermediate 
event

Escalation Intermediate (Throw): Outgoing escalation intermediate 
event

Multiple Intermediate (Catch): Incoming multiple intermediate event

Multiple Intermediate (Throw): Outgoing multiple intermediate event

Conditional Intermediate: Business rule intermediate event

Signal Intermediate (Catch): Incoming signal intermediate event

Signal Intermediate (Throw): Outgoing signal intermediate event

Parallel Multiple Intermediate: Multiple parallel intermediate event 
Link Intermediate (Catch): Incoming link intermediate event
Link Intermediate (Throw): Outgoing link intermediate event

Setting case states using Intermediate Events

Intermediate Events allow you to set a case state while executing the Business Process. The 
property Case Management > Case State configures all case states that are available throughout 
the Business Process. To set a case state, perform the following steps:

Drag an Intermediate event from the Palette to the workplace.
Select the event element, and switch to the Properties view.
Select in property Case Management > Case State a predefined case state, e.g. IN 
PROGRESS.

If property Case State doesn't provide an option yet, no case state has been defined 
for the Business Process. To manage case states, click property Case State and open 
the case state management by clicking the

button, see Managing Case States.
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When executing the Business Process, the case state will now be updated. The case state 
change is indicated by a corresponding label for the event.

2.1.3 Timer-based Intermediate

 Timer-based Intermediate: Defines a timer-based intermediate event in a Business 
Process according to BPMN 2.0 allows to set a case state using the property Case State, 
see Managing Case States.

Properties

Case Management
Case 
State

Case state to be set with this element

Possible values: Any already defined case state value; You can manage available case states 
by clicking  , see Managing Case States.

Technical
Durat
ion

Waiting time until the event occurs

Possible values:

Any duration specifying days, hours, minutes, seconds and milliseconds

9999d 23h 59m 59s 999ms: Maximum waiting time

0d 0h 0m 0s 0ms: No waiting time (Default)

 As an alternative you can define an end date using Until.

To open the waiting time configuration click on 

Label Label of the symbol within the process diagram

2.1.3.1 Setting a Timer-based Intermediate Event

Drag a Timer-based Intermediate Event from the Palette to the process diagram
Select the event component and switch to the Properties view.
Select in property Case State a predefined case state, e.g. IN PROGRESS.

As an alternative, the case state can also be set dynamically using Technical Processes.
The Case Management adapter is provided for this purpose.



 or double-click the event within the process diagram.
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5.

6.

When executing the Business Process, the case state will now be updated. The case state 
change is indicated by a corresponding label for the event.

Open the waiting time configuration by clicking the 

Configure desired waiting time by specifying days, hours, minutes, seconds and milliseconds.

Save the configuration with OK.

2.1.3.2 Setting Timer-based Intermediate Event Dynamically

Timer-based events can also be configured dynamically using Technical Processes and a 
corresponding mapping. The corresponding Technical Process is created and managed via the timer-
based intermediate event. It is created directly under the corresponding Business Process and 
cannot be moved.  

If property Case State doesn't provide an option yet, no case state has been defined 
for the Business Process. To manage case states, click property Case State and open 
the case state management by clicking the 

button, see Managing Case States.



 

As an alternative, the case state can also be set dynamically using Technical 
Processes. The Case Management adapter is provided for this purpose.



 button next to the property Duration or by double-clicking the event within the process 
diagram.

As an alternative you can define an end date using Until.
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Open the waiting time configuration by clicking the 

 Click on Create under Dynamic Configuration. 

Enter the process name and confirm by clicking OK.
The process will be created directly below the Business Process and can be edited here.

The Technical Process has to provide the following target structure:

Sample structure: Duration

<?xml version="1.0" encoding="UTF-8"?>
<timerBasedConfiguration>
    <durationDay>0</durationDay>
    <durationHour>0</durationHour>
    <durationMinute>0</durationMinute>
    <durationSecond>10</durationSecond>
    <durationMillis>0</durationMillis>
</timerBasedConfiguration> 

 button next to the property Duration or by double-clicking the event within the process 
diagram.
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Sample structure: Time stamp

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<timerBasedConfiguration>
    <untilTimestamp>2020-03-17T17:00:00</untilTimestamp>
</timerBasedConfiguration>

2.1.4 Non-Interrupting Intermediate Event

 Non-interrupting intermediate event: Defines any non-interrupting intermediate event 
within a Business Process according to BPMN 2.0 and allows to differentiate between several event 
types. In contrast to intermediate events, non-interrupt Intermediate events do not interrupt the 
processing of the bearer activity; the path initiated by the event is activated and executes parallelly.

Properties

Document Path to the corresponding process within the X4 Repository

Label Label of the symbol within the process diagram

Non-Interrupting Intermediate Events are only available within the BPMN Editor's so called 
Free-flow mode. The Free-flow mode can be enabled when creating new BPM processes and 
offers an extended palette. Unlike in default mode, the run/debug function is disabled in free-
flow mode. Moreover, the mode cannot be changed afterwards.
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Event Event type
Possible values:

Non-Interrupting Message Intermediate (Catch): In
coming non-interrupting message intermediate event

Non-Interrupting Message Intermediate (Throw): Ou
tgoing non-interrupting message intermediate event 

Non-Interrupting EscalationIntermediate (Catch): 
Incoming non-interrupting escalation intermediate event

Non-Interrupting EscalationIntermediate (Throw): 
Outgoing non-interrupting escalation intermediate event

Non-Interrupting Multiple Intermediate (Catch): 
Incoming non-interrupting multiple intermediate event

Non-Interrupting Multiple Intermediate (Throw): 
Outgoing non-interrupting multiple intermediate event

Non-Interrupting Conditional Intermediate: Non-
interrupting business rule intermediate event
Non-Interrupting Signal Intermediate (Catch): 
Incoming non-interrupting signal intermediate event

Non-Interrupting Signal Intermediate (Throw): 
Outgoing non-interrupting signal intermediate event

Non-Interrupting Timer Intermediate: Time-
triggered non-interrupting intermediate event

Non-Interrupting Parallel Multiple Intermediate: 
Multiple non-interrupting parallel intermediate event

2.1.5 End

 End: Defines a Business Process's end event according to BPMN 2.0.

Properties

Case Management
Case State Case state to be set with this element

Possible values: Any already defined case state value; You can 
manage available case states by clicking , see Managing Case 
States.

Technical
Label Label of the symbol within the process diagram
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Event Event type
Possible values:

None End: General end event (Default)

Terminate End: Cancelling end event (for all process 
instances)

Message End: Message-based end event

Cancel End: Cancelling end event (of the current process 
instance)
Compensation End: Compensation end event

Error End: End event when an error occurs

Escalation End: Escalation end event

Multiple End: Multiple end event

Signal End: End event that follows a signal

Setting case states using End Events

End Events allow you to set a case state while executing the Business Process. The property Case 
Management > Case State configures all case states that are available throughout the Business 
Process. To set a case state, perform the following steps:

Select the end element, and switch to the Properties view.
Select in property Case Management > Case State a predefined case state, e.g. IN 
PROGRESS.

When executing the Business Process, the case state will now be updated. The case state 
change is indicated by a corresponding label for the event.

If the property Case State doesn't provide an option yet, no case state has been 
defined for the Business Process. To manage case states, click property Case 
State and open the case state management by clicking the

button, see Managing Case States.



As an alternative, the case state can also be set dynamically using Technical Processes.
The Case Management adapter is provided for this purpose.
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2.2 Activities

2.2.1 Activity

 Activity: Defines an activity within a Business Process according to BPMN 2.0. The activity 
type and its execution behaviour is defined by the corresponding properties respectively by a marker. 
Activity components allow to link Technical Processes or other Business Processes as subprocesses 
from the X4 Repository.

Properties

Business
Ad hoc Marking as ad hoc activity using the symbol 
Compensation Marking as kompensating activity by the symbol 
Activity type Marking of the activity type

Available activity types:

None: General activity, without further marking (default)
 Send: Send
 Receive: Receive
 Manual: Manual activity
 Service: Service (process)
 Script: Script

Execution type Marking of the execution behaviour 
Available execution behaviour markers:

Single: Single execution (default)
 Loop: Loop
 Parallel Multi-Instance: Parallel multiple execution
 Sequential Multi-Instance: Sequencial multiple 

execution

Technical
Document Path to the linked process within the X4 Repository (set by the X4 

Designer). If a component symbol is placed from the palette via 
drag&drop to the workplace, it is only an empty process 
component without any reference to a repository file.

Label Label of the symbol within the process diagram

The marking   (subprocess) is set automatically as soon as a Business Process (*.bpm) is 
linked.
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2.2.2 Human Task

 Human Task: Human Tasks can be used to visualize human activity. When the Business 
Process is automated, these Human Tasks are linked to executable .humantask files.

Human tasks (.humantask) allow to configure the Task Management web app and thus the interaction 
with tasks performed by humans. These tasks are modeled as case management processes, see Case 
Management – Realize Tasks and Workflows.Properties

Label Label of the symbol within the process diagram

2.2.2.1 Creating and using Human Tasks

In order to better visualize human interactions in Business Processes, human task activities can be 
used when modeling processes. These can then be linked to a human task file (.humantask) in which 
the configuration of the task is made.

Human Tasks (.humantask) are created below the Business Process via the context menu New > 

Human task or via the toolbar   > Add Human task. After the creation, the Human Task is opened in 
the X4 Designer and can be parameterized as follows:

Title: Title of the task in the Task Management Web App

Description: Optional description of the task
General tab: define owner, assigned user or group and deadline for processing
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Owner: owner of the task
Assigned User/Group: Assigned user or group of 
the task.

Deadline: Deadline for resolving the task with the 
following options:

No deadline: No deadline
Duration: Deadline duration in days, hours 
and minutes
Until: Date and time at which the task must 
be resolved
Case State: Case state to be executed 
automatically, if the human task's deadline 
was reached.

Tab Business Data: Define information to be displayed within the Task Management Web App
Key Identifier: Case feature as key identifier 
within the Task Management Web App
Categories, feature groups and features are 
displayed in a tree structure and can be selected 
in order to be visible within the Task 
Management web app

 Categories are displayed as tabs within the Ta
sk Management web app.
Display Name: Display name of the selected 
category, feature group or feature
read only: Mark selected category, feature 
group and feature as read-only

Tab Actions: Define actions to be performed within the Task Management Web App 

The involved users and groups are created 
and managed in Keycloak.



If a human task with a deadline is 
executed, the process is 
automatically resumed with the 
configured case state after the 
specified deadline was reached. In 
this case, the human task is 
automatically closed and displayed 
within the Task Management Web 
AppTask Management Web App's 
navigator node Verfallen (expired). All 
human tasks that have exceeded the 
deadline and have been closed 
automatically are displayed here.

If no case state was set, the process 
won't be continued automatically. 
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In Actions the case states to be set by the 
corresponding user within the Task Management 
Web App can be defined
Display Name: Display name of the selected 
case states within the Task Management Web 
App

Tab Settings: Advanced settings for case processing
Under Advanced you can allow declining and forwarding of 
tasks and enable accessing human tasks via interface, see 
also Accessing Human Tasks via ReST API.

Task can be declined: Allow declining tasks
Task can be forwarded: Allow forwarding 
tasks
Task can be resubmitted: Allow 
resubmitting tasks
Enable access via API: Allow accessing the 
task via interface

Under Documents, you can allow adding, editing and deleting 
documents related to a case.

Enable Documents: Allow processing 
documents
Documents can be added/edited: Allow 
adding and editing documents
Documents can be deleted: Allow deleting 
documents

2.2.2.2 Parameterizing Human Tasks Dynamically via Technical Processes

Human tasks can not only be configured via the human task files, but also dynamically via Technical 
Processes.

The following human task settings can be overridden in the Technical Process:

The Task Management adapter allows to define 
additional actions for a human task.



Execution on the X4 Server
If a Business Process runs on a human task during execution, the execution of the process is 
stopped and the human task is generated. The process waits for the necessary human 
interaction within the Task Management Web App and continues execution as soon as the 
human task is completed.
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1.
2.
3.

Owner
Assignee
Deadline

The Technical Process for parameterizing the human task is created directly under the corresponding 
human task via the context menu New > Technical Process and cannot be moved.

The input and output document for the process is structured as follows:

Structure of the input and output document

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<HumanTask>
    <Owner>OwnerName</Owner>
    <Assignee>
        <name>AsigneeName</name>
        <type>user|group</type>
    </Assignee>
     
    <!-- Deadline types (NoDeadline, DurationDeadline, UntilDeadline)-->
    <NoDeadline />
 
    <DurationDeadline>
        <Days>7</Days>
        <Hours>4</Hours>
        <Minutes>45</Minutes>
    </DurationDeadline>
 
    <UntilDeadline>2019-04-18T14:30:49+02:00</UntilDeadline>
</HumanTask>

2.2.2.3 Accessing Human Tasks via ReST API

Instead of the Task Management Web App, also other applications can be used to display and edit 
human tasks. The implementation is done via ReST interface, which offers all functionalities also 
available in the Task Management Web App.

To enable the connection via the ReST interface, the following settings must be made:

Open the human task.
Open the tab Settings.
Under Advanced select the option Enable access via API. 
Accessing human tasks is now only possible via the interface.

Access to the human task via the ReST interface can be enabled separately for each .humant
ask file.
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2.2.2.4 Authenticate via ReST interface

To authenticate via the ReST interface, use the "Basic" HTTP authentication scheme or an X4 token.

Depending on the used authentication scheme, the HTTP request header has to be as follows:

"Basic" HTTP authentication scheme

Parameters Value
ReST Request Method GET

Host X4-Server:Port

Path /X4/services/rest/tasks/login

ReST Request 
Header

Header name Authorization

Header value Basic <Username:Password>

You will receive an X4 token (JSON Web Token) that you can use for further ReST requests.

Example Header

authorization: Basic YWRtaW46ZGVtbw==

Documentation of the ReST interface can be found at http://localhost:8080/X4/X4Api/.

Username:Password is set as a base64 encoded 
string.



http://localhost:8080/X4/X4Api/
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X4-Token

For further ReST requests, the ReST request header has to be as follows:

Parameters Value
ReST Request 
Header

Header name Authorization

Header value X4Token <X4-Token>

Example Header

authorization: X4Token J0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9...
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2.2.3 Rule

 Rule: The rule component allows to depict rules for decisions within a Business 
Process. The rules to be applied are defined within decision tables (.rule) according to DMN 1.1. The 
rules can be automatically checked and the results will be passed to the Business Process for further 
processing.

Properties

Label Label of the symbol within the process diagram

2.2.3.1 Creating and Defining Rules

DMN is a standard for modeling decisions within Business Processes. The standard DMN also 
defines the Simple Expression Language (S-FEEL), a formal expression language for defining 
a decision logic.
DMN 1.1 with S-FEEL is available online under https://www.omg.org/spec/DMN/1.1/.



•
•

Default values of type Integer and Decimal cannot be empty.
For the types Integer and Decimal it is not possible to check if the value is empty.



https://www.omg.org/spec/DMN/1.1/
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To better depict rules for decisions in Business Processes, rule modules can be used when modeling 
Business Processes. These can then be linked to a decision table (.rule) in which the rules are 
defined.

Decision tables (.rule) are created below the Business Process via the context menu New > Rules or 

via the toolbar   > Add rules. After the creation, the decision table is opened in X4 Designer.

No. Element Description

1 Toolbar Functions for editing decision tables, depending on context and selection

Combining decision tables
Any number of decision tables can be combined in a Business Process. Output values of one 
table thus become input values of the following tables. Thus, complex decision trees with 
corresponding branches can be modeled.
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1.
2.

•

•
•
•
•

•
•

No. Element Description

2 Header area Settings for defining input and output, whereby several inputs and outputs 
are possible.

The following cells are available to define the input and output:

Free text field for the column name
Input or output source
Input / Output: Input from the BPMN process respectively output to 
be passed to the BPMN process
Placeholder: Selection of a placeholder (only available for input)
Variable: Value stored in a variable
Case State: Selection of a status 
Case Feature: Selection of case data

Data type of the input or output  (string, number, boolean)
Input path as free text field or selection (depending on the input source) respectively name of the 
output or variable as free text field or selection (depending on output destination)
3

Annotation

Comment field that is not displayed in the output

4

Rules

Rules determining how inputs are to be transformed into outputs.

Rules are defined per line in the decision table, whereby the row order determines the check order. A 
rule has at least one column for processing the input values (Input) and at least one decision result 
(Output).

Rules in the decision table are entered in the S-FEEL notation. This allows the decision logic to be 
described in natural language "business-friendly". As a formal markup language with fixed semantics, 
grammar and defined rules, it allows at the same time the interpretation and execution of values. S-
FEEL can interpret strings, numbers, simple arithmetic operations and simple comparison tests.

•
•
•

•

Please note:
Set strings in quotation marks, e.g. "Head of department".
For decimal numbers, use a dot as separator, e.g. 5.1.
If the value of a cell within the input column is not relevant for a rule, enter according to 
S-FEEL a - (minus sign) into the cell.
A decision table can contain a fallback rule that always applies. For this purpose, all 
cells of the input columns of a fallback rule contain a - (minus sign). 
Whether a fallback rule makes sense and where it should be in the check sequence 
depends on the hit policy and the use case.
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•

5

Hit policy

Setting regarding the displayed results. It determines how many rules of a decision table can apply 
and how the results are output.

Significance Possible hit policy violation

U (Unique): Only one rule can match and exactly one 
result is output.

No applicable rule
Multiple applicable rules

F (First): One or several rules may apply, but only the 
first result is output.

 Consider the check order!

No applicable rule

A (Any): One or several rules with the same result may 
apply, but only one result is output.

No applicable rule
Multiple applicable rules with different 
results

C (Collect): All applicable results are output without a 
fixed output sequence.

No applicable rule

Rules can be defined in a way that the number and selection of results violates the Hit Policy. 
In this case, the rules or the hit policy must be corrected depending on the application.



•
•
•

The finished BPMN process with the decision table can be validated and checked for errors 
within the X4 Designer and executed on the X4 Server.
Decision tables can lead to three results:
Icon Description

The Rule component returns one or several results. The intermediate 
result can be opened.

The Rule component does not return any results. Possible causes:

None of the defined rules apply to the input.
The rules are incorrect, e.g. spelling error.
The hit policy is not suitable.

The Rule component returns an error because the decision table does 
not conform to S-FEEL. A report with an explanation of the error can be 
opened.
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•

2.2.3.2 S-FEEL Expressions for Defining Rules

Operator / Expression Description

Comparis
on

10 Checks whether the input value corresponds to the 
specified value, e.g. 10

v:[Variablename]
f:[Featurename]
p:
[Placeholdername]
c:[CaseState]

Performs a check based on a variable, feature, custom 
placeholder, or case state

<  Checks whether the input value is smaller than the 
specified value, e.g. < 10

<= Checks whether the input value is less than or equal to the 
specified value, e.g. <= 10

>  Checks whether the input value is greater than the 
specified value, e.g. > 10

>= Checks whether the input value is greater than or equal to 
the specified value, e.g. >= 10

not() Checks whether the input value is not less than or equal to 
the specified value, e.g. not(<=10)

Interval [1..10] Checks whether the input value is greater than or equal to 
the start value and less than or equal to the end value.

(1..10] Checks whether the input value is greater than the start 
value and less than or equal to the end value.

[1..10) Checks whether the input value is greater than or equal to 
the start value and less than the end value.

(1..10) Checks whether the input value is greater than the start 
value and less than the end value.

Disjunctio
n

3,5,7 Checks whether the input value is 3,5 or 7.

By pressing the shortcut Ctrl + Space all currently 
available variables, features, custom 
placeholders and case states are displayed in a 
drop-down list.
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•

<2,>10 Checks whether the input value is less than 2 or more than 
10.

10,[20..30] Checks whether the input value is either 10 or between 20 
and 30.

"Meier", "Müller, "Weber" Checks whether the input value is either Meier, Müller or 
Weber.

2.3 Sequence Flow

 Sequence Flow: Connects events, gateways, and activities of a Business Process, and defines 
a sequence of process actions by the sequence flow's arrow direction.

Properties

Label Free text area to set a label to the sequence flow (for a clearer layout or 
documentation purposes)

Log4J Log Enable logging via Log4j at this position in the process using current input data; To 
enable Log4j logging, select the property, and click .

Possible values:

Disabled: No Log4j action has been defined (default)

Enabled: A Log4j action has been defined

An extensive reference to the syntax of the S-FEEL notation can be found in the current 
specification for DMN 1.1 (Chapter 9) of the Object Management Group under https://
www.omg.org/spec/DMN/1.1.



As soon as you move the mouse over Events, Gateways or Activities, an arrow appears at the 
bottom right edge of the element. Click and drag the arrow to create a sequence flow line.



https://www.omg.org/spec/DMN/1.1
https://www.omg.org/spec/DMN/1.1
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•
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•
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•
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•

BAM Log Enable logging via X4 BAM at this point in the process with the current input data; To 
enable BAM logging, highlight the property and click on .

Possible values:

Disabled: No BAM Logging action has been defined (default)

Enabled: BAM Logging action has been defined

Save Point Set Save Point at this point of the process to persist the complete state of the process 
engine with the processed data and state information when executing a process 
instance in the file system. The process instance can be restarted from the last saved 
Save Point via X4 BAM.

Possible values:

No Savepoint: No Save Point has been defined (default).

Save and Continue: Create Save Point and directly continue process execution

Save and Stop: Create Save Point and stop the execution of the process instance

Delete: Delete current Save Point

Priority For forks (Parallel Gateways (Forking)) and branches (Exclusive Gateways 
(Forking)): Position in the execution order (priority)

Possible values:

Any positive integer

1: Highest priority (default)

Condition For condition blocks: Execution condition stored by the Condition Manager.

2.4 Gateways
Within Business Processes (process diagrams with file extension .bpm) you can use the following 
gateways according to BPMN 2.0:

2.4.1 Parallel Gateways
Parallel Gateway 
(Forking)

Defines a parallel gateway for logical AND branching according to BPMN 
2.0.

Parallel Gateway 
(Synchronizing)

Defines a synchronizing gateway for parallel sequence flows according to 
BPMN 2.0.
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1.

2.

3.

4.
5.

Properties

Lab
el

Free text area to set a label to the branching, respectively the joining (for a clear layout or 
documentation purposes)

Using parallel gateways

Drag a Parallel Gateway (Forking) element from the Palette to the process diagram 
via drag&drop.
Create a sequence flow line for each execution branch to the Parallel Gateway 
(Forking) element.
All execution branches are executed independently and use the same input. 
If necessary, change the property Priority of a selected sequence flow line to change the 
execution order of the branches.

Drag a Parallel Gateway (Synchronizing) element from the Palette into the process diagram.
Connect the sequence flow lines of the execution branches with the Parallel Gateway 
(Synchronizing) element.
In executable processes, the output documents of the last executed process component in the 
fork will be handed over to the next process steps.

Example: Parallel gateway (forking) with 3 parallel, priorized branches and a Parallel gateway (join)

2.4.2 Inclusive Gateways
Inclusive Gateway 
(Forking)

Defines a data-based inclusive gateway for logical OR branching 
according to BPMN 2.0

Inclusive Gateway 
(Synchronizing)

Defines a synchronizing gateway to join exclusive databased sequence 
flows

If sequence flows are modeled "parallely" with Parallel gateways, this doesn't mean they are 
executed simutaneously, but that they are equivalent. Within the property Priority, you can 
define the actual execution order of parallel sequence flows, see Sequence flow.



In executable processes the execution branch with the lowest Priority number will 
be executed first.
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1.

2.

Properties

Label Free text area to set a label to the branching, respectively the joining (for a clear layout or 
documentation purposes)

Condi
tion

Execution condition (is set by the Condition editor automatically) for the forking; Double-
click on the transition line to define conditions or click on   to open the Condition editor.

Example: Inclusive gateway (forking) with 3 exclusive branches and a synchronizing Inclusive gateway 
(synchronizing):

2.4.3 Exclusive Gateways
Exclusive Gateway 
(Forking)

Defines a gateway for exclusive forkings according to BPMN 2.0

Exclusive Gateway 
(Synchronizing)

Defines a synchronizing gateway for parallel sequence flows according 
to BPMN 2.0 

Properties

Label Free text area to set a label for the exclusive forking, respectively 
the synchronizing (for a clearer layout or documentation purposes)

Condition Execution condition of the forking (is set by the Condition 
editor automatically); Double-click on the transition line to define 
conditions or click on   to open the Condition editor.

Using Exclusive Gateways

Drag an Exclusive Gateway (Forking) element from the Palette to the process diagram 
via drag&drop.
For each execution branch, create a sequence flow line beginning from the Exclusive Gateway 
(Forking).
All execution branches use the same input.

In practice, constructs with Inclusive gateways often make little sense. Thus, BPM experts 
recommend to avoid these elements, and to use a combination of Exclusive and Parallel 
gateways instead.
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3.

4.

5.

6.

Double-click the Exclusive Gateway (Forking) element to define the conditions for the single 
execution branches.
The Condition Editor will be opened. Here, you can define a condition for each 
selected sequence flow line, see Creating conditions.
If necessary, change the property Priority of a selected sequence flow line to change the 
execution order of the branches.

Drag an Exclusive Gateway (Synchronizing) element from the Palette into the process diagram 
at the point where more than one execution branches shall be joined.
Connect the sequence flow lines of the execution branches with the Exclusive Gateway 
(Synchronizing) element.
When the Business Process is executed, the output document of the last executed process 
component in the fork will be handed over to the next process steps, just like in Technical 
Processes.

Example: Exclusive gateway (forking) with 3 exclusive forks and synchronizing exclusive 
gateways (synchronizing)

2.5 Artefacts
Within a Business Process (process diagrams with the file extension .bpm) you can use the following 
artefacts according to BPMN 2.0:

2.5.1 Message flow
 Message Flow: If several pools are used to model a collaboration between different parties, the 

information interchange between the pools is marked with a message flow component.

When executed, the Business Process's execution branch with lowest Priority numb
er will be executed first.



Since BPMN-compliant Business Process do not provide Variable components, context 
variables can only be evaluated if they were defined within a Technical Process and those 
Technical Processes are linked to the Business Process as activities. In the Business 
Process, context variables can be evaluated that were initialized within linked Technical 
Process, but not within the Technical Processes' subprocesses.
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Properties

Label Free text area to label the message flow (useful to layout/
document the process diagram)

Line Routing Line routing

Possible values:

Angled: Angled line

Straight: Straight line (Default)

Line Type Line style

Possible values:

Dash line: Dashed line (Default)

Solid line: Solid line

Dot line: Dotted line

Line Color Message flow color; To change the color select the 
property and click .
Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be 
selected with an color picker dialog)

RGB(0,0,0): Black (Default)

Please note that message flows can only be used to visualize logical coherences!
When executing the Business Process on the X4 Server, only process components are 
interpreted as data and control flow elements that have been connected with sequence flow 
lines, see Sequence Flow.
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Line Source Decorator and Line 
Target Decorator

Symbol for the beginning and the end of the line

Possible values:

Circle: Circle/ellipse (Default)

Empty arrow: Empty arrow

Association arrow: Open arrow

Arrow: Filled arrow

Inverted arrow: Inverted arrow

Diamond : Filled rhombus

Empty diamond: Empty rhombus

Plain : No symbol

2.5.2 Association

 Association: Logical connection between process components (events, gateways or activities) 
and artefacts (such as pools, data objects, annotations or groups) or other drawing elements within a 
Business Process.

Properties

Label Free text area to label the association (useful to layout/
document the process diagram)

Line Routing Line routing

Possible values:

Angled: Angled line

Straight: Straight line (Default)

Line Type Line style
Possible values:

Dash line: Dashed line (Default)

Solid line: Solid line

Dot line: Dotted line

Please note that association lines can only be used to visualize logical coherences!
When executing the Business Process on the X4 Server, only process components are 
interpreted as data and control flow elements that have been connected with sequence flow 
lines, see Sequence Flow.
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Line Color Association color; To change the color select the property 
and click  .
Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be 
selected with an color picker dialog)

RGB(0,0,0): Black (Default)

Line Source Decorator and Line 
Target Decorator

Symbol for the beginning and the end of the line
Possible values:

Circle: Circle/ellipse (Default)

Empty arrow: Empty arrow

Association arrow: Open arrow

Arrow: Filled arrow

Inverted arrow: Inverted arrow

Diamond : Filled rhombus

Empty diamond: Empty rhombus

Plain : No symbol

2.5.3 Pool/Lane

 Pool/Lane: Structures a Business Process into responsibilities and roles according to BPMN 
2.0. Lanes are defined within one or multiple pools and represent the activities' responsibility. Pools 
represent participating organizations, systems etc. A pool can contain any number of lanes.

Properties

Pool Name Free text name of the pool (if a pool is selected)

Lane Name Free text name of the lane (if a lane is selected)

Line Color Line color of the pool or the selected lane; To change the color, select the property 
and click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected via a color picker 
dialog)

RGB(0,0,0): Black (default)
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2.
•
•
•

Line Width Line width of the pool or of the selected lane in pixels
Possible values:

Any positive integer number

1: Line with 1 pixel width (Default)

Fill Color Fill color of the pool or a selected lane; To change the color select the property and 
click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected via a color picker 
dialog)

RGB(255, 255, 255): White (default)

Using Pools/Lanes in Business Processes

Pools outline involved organizations, systems etc. and may contain multiple lanes. In the pool/lane 
layout, the chronological progress is visualized mostly from upper left to lower right.

Insert and edit a pool:
Drag the Pool symbol

 from the Palette to the workplace via drag&drop.
Scale the pool by clicking and holding the corner handles.
Change the text label of a pool: In the Properties view enter another text in Pool Name.
Change the formatting: Select the property Fill Color or Line Color in 
the Properties view, and click 

 to open a color palette.
Add and edit a lane:

Right-click on a pool, and select Add Lane from the context menu.
Change the text label of a lane: In the Properties view enter another text in Pool Name.
Change the formatting: Select the property Fill Color or Line Color in 
the Properties view, and click 

 to open a color palette.

2.5.4 Data object

Data Object: Includes any data object, e. g. a file from the X4 Repository.

Properties
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Document Path to the linked document within the Repository.

Label Label of the symbol within the process diagram

Operation Defines, if the file is to be read or written
Possible values:

Read: Read the document into the process, and output content to the next process 
action (default)

Write: Write the document with the data received from the preceding process 
action

2.5.5 Data store

Data Store: Is used to visualize a database that is used.

Properties

Document Path to the linked document within the Repository

Label Label of the symbol within the process diagram

Operation Defines, if the file is to be read or written
Possible values:

Read: Read the document into the process, and output content to the next process 
action (default)

Write: Write the document with the data received from the preceding process 
action

2.5.6 Annotation

 Annotation: Inserts a free annotation whose text can be edited and formatted via double-click 
in a corresponding dialog.

Properties

Please note that data stores are exclusively used for the visualization of logical connections!

You can link an annotation with a process component by using an association line.
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Hyperlink Linking defined for the annotation. To create a link enter a valid URL.

 You can open the linked URL with Ctrl + click.

Text Text of the annotation; To change and format the text select the property and 

click   

Fill Color Fill color of the annotation; To change the color select the property and click 
.

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected via a color picker 
dialog)

RGB(255, 255, 255): White (default)

Transparent Set annotation as transparent. By enabling this property the property Fill 
Color will be ignored.

2.5.7 Group

 Group: Groups process elements visually in order to show their coherence.

Properties

Line Color Line color of the group; To change the color select the property 

and click   
Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected 
with an color picker dialog)

RGB(160,160,160): Grey (default)

Line Width Line width of the group element
Possible values:

Any positive integer number

2: Dashed line with 2 pixel width (default)

2.6 Drawing
Which drawing elements can be used for all process types.:
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2.6.1 Connection

Connection: Passes the input and the execution state of the preceding process action without 
modification. It marks the execution branch explicitly for the X4 Server. Within a loop this component 
marks the return to the first loop component. It connects a Condition component with a Stop comp
onent, or helps to change a transition line's position.

Properties

Label Text label of the symbol in the process diagram (can also be edited by pressing F2)

Examples

Connection between condition and the last loop component: Within loops, a Connection comp
onent is used as last loop component. 

Connection between condition and stop: Between a Condition component and a Stop compo
nent, a Connection component is used. 

Connection to position the transition line: Transition lines are normally positioned 
automatically. To change the positioning explicitly a connection can be used.

2.6.2 Connector

Connector: Creates a logical connection between elements
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Properties

Label Free text area to label the connector line (useful to layout/
document the process diagram)

Line Routing Line routing

Possible values:

Angled: Angled line

Straight: Straight line (Default)

Line Type Line style
Possible values:

Dash line: Dashed line (Default)

Solid line: Solid line

Dot line: Dotted line

Line Color Connector line color; To change the color select the 

property and click  .
Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be 
selected with a color picker dialog)

RGB(0,0,0): Black (Default)

Connector lines can only be used to visualize logical coherences!
When executing the Business Process via the X4 Server, only process components are 
interpreted as data and control flow elements that have been connected with Sequence 
Flows in Business Processes, and those components that are connected with Transitions in 
Technical Processes.
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Line Source Decorator and Line 
Target Decorator

Symbol for the beginning of the line
Possible values:

Circle: Circle (Default)

Empty arrow: Empty arrow

Association arrow: Open arrow

Arrow: Filled arrow

Inverted arrow: Inverted arrow

Diamond: Filled rhombus

Empty diamond: Empty rhombus

Plain: No symbol

2.6.3 Rectangle and Ellipse

 Rectangle
Draws a rectangle

 Ellipse
Draws an ellipse

Properties

Line Color Border color of the drawing element; To change the color select the 
property and click  .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected with a color 
picker dialog)

RGB(0,0,0): Black (Default)

Line Width Width of the drawing element's border

Possible values:

Any positive integer number

1: 1 Border with 1 pixel width (Default)

Hide Line Hide border of the drawing element
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Fill Color Fill color of the drawing element; To change the color select the property 
and click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected with a color 
picker dialog)

RGB(255,255,255): White (Default)

Transparent Set drawing element as transparent. By enabling this property 
the property Fill Color will be ignored.

2.6.4 Textbox

 Textbox: Inserts a text box, whose content can be edited and formated in a dialog by double-
clicking the box.

Properties

Hyperlink Linking defined for the textbox. To create a link enter a valid URL.

 You can open the linked URL with Ctrl + click.

Text Content of the text box; To edit and format the text select the property and 
click .

Rotation Rotation of the text box in degree

Possible values:

0: No rotation (Default)

90: Rotate by 90°

180: Rotate by 180°

270: Rotate by 270°

Fill Color Fill color of the text box; To change the color select the property and click 
.

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected via a color 
picker dialog)

RGB(255, 255, 255): White (default)
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Transparent Set text box as transparent. By enabling this property the property Fill 
Color will be ignored.

2.6.5 Polygon

Polygon: Draws a polygon with multiple corner marks

Properties

Line Color Border color of the drawing element; To change the color select the 

property and click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected via a color 
picker dialog)

RGB(0,0,0): Black (Default)

Line Width Width of the drawing element's border

Possible values:

Any positive integer number

1: Border with 1 pixel width (Default)

Fill Color Fill color of the drawing element; To change the color select the property 
and click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected with a 
color picker dialog)

RGB(255,255,255): White (Default)

Transparent Transparent fill (do not use a fill color); By enabling this property 
the property Fill Color will be ignored.

2.6.6 Polyline and Line

 
Polyline

Draws a line with multiple way points

 Line
Draws a straight line
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Properties

Line Color Border color of the drawing element; To change the color select the property 

and click .
Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected with a color 
picker dialog)

RGB(0,0,0): Black (Default)

Line Width Width of the drawing element's border
Possible values:

Any positive integer number

1: Border with 1 pixel width (Default)

2.6.7 Image

 Image: Inserts an image frame that allows to include a .gif, .jpg, .png, or a .bmp image file.

Properties

Line Color Border color of the image frame; To change the color select the property and 

click .

Possible values:

RGB(RRR,GGG,BBB): 24 bit RGB color code (can be selected with a color 
picker dialog)

RGB(0,0,0): Black (Default

Line Width Width of the drawing element's border

Possible values:

Any positive integer number

1: Border with 1 pixel width (Default)

Image File Path to the linked image file

The inserted image will be stored within the process.
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3 Working with BPM Projects
The X4 Repository is organized in projects. Projects have a file system structure and can contain any 
folders, processes, process components and other files.

3.1 The Structure of BPM Projects
BPM projects have a predefined and unchangeable folder structure, which is created 
automatically when a new BPM project is created.

Project At top level of a BPM project process landscapes (.pld) can be 
created.

Processes Within the Processes folder any number of BPM processes (.bpm) 
can be created. Here is also the Activities folder with his 
predefined structure.

Activities The Activities folder contains the following subfolders, which 
can contain only predefined filed:

Adapters: Here only folders and adapter files (.fa and .tr
a) can be created
DomainModel: Here any number of .domainmodel files can 
be created in which the business case data is defined
Processes: Here you can store technical processes (.wrf) 
in order to link them to your activities
Resources: Folders, resources such as images, text and 
XML documents and other files can be stored here.
TemproraryFiles: Temporarily used files are stored here.
Transformations: Transformations (.xsl) and reports 
(.rep) are stored here.

Resources Folders, resources such as images, text and XML documents and 
other files can be stored here.

3.2 Creating BPM Projects
There are different options to create BPM projects:

Via New BPM Project on the X4 Designer Welcome page
Via the context menu New > BPM Project within the Repository Navigator
Via the menu File > New > BPM Project

The automatically created folders and subfolders cannot be deleted, moved or renamed.



X4 BPM

© SoftProject GmbH 76

1.

2.
3.
4.

Select the menu File > New> BPM Project within the X4 Designer.

Select an empty project template or an already existing template.
Enter the project's name in Project name.
Click Finish to create the project.
An empty BPM project with the predefined structure is created within the Repository 
Navigator.

3.3 Templates
In X4 Designer, you can choose from several templates when creating a project.

3.3.1 ESB Project
Category Template Description
Basics ESB Introduction This project contains a brief introduction to Technical 

Process modeling.
XSLT Introduction This project contains a brief introduction to creating 

XML data transformations.
Database Create Data This project contains an example of creating data in a 

database using the JDBC Connector adapter.
Delete Data This project contains an example of deleting data from 

a database using the JDBC Connector adapter.
Read Data This project contains an example of reading data from 

a database using the JDBC Connector adapter.
Update Data This project contains an example of updating data in a 

database using the JDBC Connector adapter.

The various elements of a BPM project can now be created via the context menu. The 
available options change depending on where in the tree structure the context menu is 
opened.
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E-Mail Send e-mails with the 
POP/SMTP adapter

This project contains an example of sending e-mail 
using the POP/SMTP adapter.

3.3.2 BPM Project
Category Template Description
Basics BPMN Introduction This project contains a brief introduction to 

Business Process modeling.
Demos Approve electronic invoice This demo includes an approval process for 

electronic invoices. It includes Business 
Processes, Business Rules (DMN) and Human 
Tasks.

3.3.3 Web App Project
Category Template Description
Components Calendar Component This Web App is an example of a Calendar 

Component with appointments.
Grid Component This Web App is an example of displaying data in 

tabular form in the Grid Component.
Controls How to use Controls This project contains examples of how to use the 

most common Controls in X4 Web Apps.
TextBlock This project contains examples of how to use the 

TextBlock control in X4 Web Apps.
Demos Manage your customer data In this demo you can manage your customers, 

their address data as well as contact persons.
Report a street lighting 
malfunction

In this demo, a customer can report a 
malfunction in the street lighting system. The 
data is stored in a database.

Layouts How to use layouts This project contains examples of using layouts in 
X4 Web Apps.

Properties Data Context This project contains an example of how to use 
properties of the same context in several 
components.

3.4 Modelling Process Landscapes
Process Landscapes enable to provide a clear presentation of process landscapes within the X4 
Designer and to link processes and other documents.
Process landscapes allow to plot all relevant processes and to document their logical connection in a 
compact way. Thus, a process landscape provides a bird's eye view on management processes, value 
chains, and support processes and provides a basis for quality management.



X4 BPM

© SoftProject GmbH 78

Process landscapes are created at the highest level of a BPM project. Each BPM project may only 
contain one process landscape with the project name as name, e.g. Demoproject.pld. Process 
landscapes are not executable, but provide an overview of Business Processes that can be linked 
using Block Arrow elements. In addition, with Data Objects you can link any other repository file. 

3.5 Creating a Business Process
The BPMN Designer enables to model Business Processes according to BPMN 2.0.
To create an executable Business Process, you can drag empty process components from the palette 
or repository files to the workplace, and configure the corresponding properties in the Properties vie
w.

The Free-flow mode additionally allows to use the BPMN Designer as plain BPMN drawing tool 
with an extended BPMN palette where the run/debug functionality is disabled.





X4 BPM

© SoftProject GmbH 79

1.

2.
3.

4.

5.

6.
7.

8.

9.
•

Create a new business process within the Processes folder e.g. via the context 
menu New > Business Process.

Select an empty project template or an already existing template.
Enter the Business Process name within File name.

 Blanks and umlaut characters are not allowed in file names! 
Click Next to enter further process information.

Enter a process title within Process title.
The process title will be displayed in the Business Process and can be changed with the 
property Title and hidden or shown with the property Show Title within the Properties view.
If required, enter a process description within Process description.
If required, enable the free-flow mode for business processes under Free-flow mode and use 
the BPMN Designer as plain BPMN drawing tool with an extended BPM palette.

 The run/debug functionality is disabled in the free-flow mode.
Click Finish to create the business process.
An empty Business Process will be saved in the repository with the file extension .bpm, and will 
be opened in the BPMN Designer. 
Model the Business Process as desired:

Create Sequence Flow connection lines :
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Move the mouse cursor over the Start component to display a small triangle. 
Click on the triangle, and drag it to the target component to create a sequence 
flow.

Insert elements from the Palette or from the Repository Navigator to the sequence 
flow via drag&drop.

Insert Pools and Swimlanes, see Pool/Lane.
Insert Event elements, see Events.
Insert Parallel Gateway elements or Exclusive Gateway elements, 
see Gateways

3.5.1 Use of private files within Business Processes
If process resources are only to be used within a Business Process, they can be created directly 
within a parent process. This means that they can only be used in the process context and cannot be 
called up from other Business Processes.

In general, the same resources can be created within a single Business Process as within a BPM 
project - be it further Business Processes (.bpm), Technical Processes (.wrf), human tasks 
(.humantask), rules (.rule) or domain models (.domainmodel).

Tipp
An integrated process validator allows the process to be checked for validity via 
the menu Project > Validate Project.
If you link repository files in your business process, and configure all properties 
in the Properties view correspondingly, you are able to execute the business 
process by clicking . Excepted are processes in Free-flow mode.



The resources to be used can be created both via the context menu New > <resource name>
and via the toolbar  > Add <resource name>.
The created resources can then be parameterised as usual and incorporated into the process 
diagram via drag & drop from the repository, see also Human Task, Rule, Managing Case 
States.
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3.6 Importing Business Processes in BPMN or XML Format
The BPMN 2.0 Import Wizard allows to import process diagrams in .xml or .bpmn format from third 
party modelling tools as new Business Processes into the X4 Repository.

Open the BPMN 2.0 Import Wizard  via the menu Project > Import BPMN 2.0 Process.

Click Browse to select the desired file.

Select the file and confirm the dialog.
The file is now selected within the Wizard.
Click Finish to import the file.
The file has been imported and is displayed as Business Process in the Repository Navigator.

3.7 Properties of Business Processes (.bpm)
Business Processes (.bpm) are modelled graphically using the BPMN Editor and can be executed on 
the X4 Server , if all modules are parameterized and linked correctly with repository files.

You can filter for the file via the .xml (default) or .bpmn extension.
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Properties

Documentation
Created Creation date of the process
Created by Creator of the process
Last Update Date of the last change
Last Update by Name of the last editor
Title Free text field for the process title

Version Project version

 If no version is set, the time stamp is taken as version.

Technical
Can Stop Business Process may be stopped during execution

 This property is not inherited by subprocesses.

Possible values:

True: For standard processes (default)

False: For critical processes that need to be completed

Free-flow mode Defines if the free-flow mode is enabled. This unlocks the extended BPMN
palette to use the BPMN Editor as a pure BPMN drawing tool.

•

•

You can edit the properties of a Business Process in the Properties view by clicking on a free 
area of the BPMN Editor's workspace.
The most common properties are displayed by default, however, additional settings can be 
made using the Properties view toolbar:

 Show Categories: Show properties sorted by categories

 Show Advanced Properties: Show advanced properties



•

•

This option can be enabled when creating a Business Process and 
cannot be changed afterwards.
The run/debug functionality for the current Business Process is 
disabled in Free-flow mode.
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In service Set process active or inactive. If inactive processes are executed, they receive 
the process ID -1. Subprocesses (processes called from other processes) can 
always be executed independently of this property.

Possible values:

True: Process can be executed (default)

False: Process cannot be executed (only called as subprocess)

Instance limit Maximum number of instances of this process that can be executed at the same 
time.

Schedule Time scheduling tool enabling the scheduled execution of processes on the X4
Server without X4 Designer; To schedule a process, select this property, and 
click .

Possible values:

Disabled: No schedule is defined (default)

Enabled: A schedule for this process is defined

Stop on error Stop the process execution if an error occurs

Possible values:

True: Stop execution if an error occurs (default)

False: Continue erroneous execution (if possible)

Schema 
Declaration

Define schema for input and output of the process

3.8 Aligning process components
Process components can be aligned easily via context menu entry Layout. This allows you to generate 
a clean and structured model quickly and easily.

To align process components, select the required components and open the context menu by right-
clicking. Then select Layout and the desired option. The following options are available:

Align Horizontal: Align the process components horizontally
Align Vertical: Align the process components vertically
Distribute Horizontal: Distribute the process components horizontally
Distribute Vertical: Distribute the process components vertically

Please note!

Instance limit is ignored, if the process is executed as subprocess.
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3.9 Adding Process Metadata
You can add metadata to the process definition of a Business Process or Technical Process, e.g. for 
documentation purposes.

In the Process Designer, click on an empty spot in the drawing area to display the process 
diagram's properties in the Properties view.

Select property Metadata > Manage Metadata, and click  .
A dialog will be opened where you can define key/values pairs.

Enter the metadata properties:
In Name, enter the metadata name, e.g. Version.
In Value, enter the corresponding metadata value, e.g. 1.1.

To change the sequence of a selected metadata entry, click Up or Down.
Click OK to save the metadata.
The metadata have now been added and are displayed in the Properties view. The metadata will 
be saved in the XML storage format of the process definition file.

For the options Align Horizontal and Align Vertical at least two process components 
must be selected, for the options Distribute Horizontal and Distribute Vertical at 
least three.
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3.10 Import projects
Here you will learn how to import projects and other resources from the local file system into the 
repository.

3.10.1 Import via drag and drop
From the file system (e.g. from the desktop or Windows Explorer), you can import one or more marked 
files into the Repository Navigator and thus into the currently connected repository via drag and drop. 
If a file with the same name already exists at the destination, you will be prompted to enter a new 
name.

3.10.2 Using the Import Wizard for files and projects

In the menu, click Project > Import.
The Resource Import Wizard is opened.
Select resource.

Select the file to be imported (*.zip) or the project to be imported via Browse and enter 
the corresponding name in New project/file name.

Click Finish.

The Remove button allows you to delete selected metadata from the list.

•

•

•

•

Note:
Folder structures are not supported during import, use the corresponding wizard for 
this.
For larger file transfers (over 1 MB in total), a confirmation dialogue will be displayed as 
there may be delays in the transfer as well as memory problems.
Imported files that contain special or space characters or umlauts in the file name must 
be renamed before you can open them in X4 Designer.
Projects have a predefined structure so that the inserted files can only be stored in the 
respective predefined folder, see also The Structure of ESB Projects



•

•

Note
Projects have a predefined structure so that the files to be imported can only be stored 
in the respective predefined folder, see also The Structure of ESB Projects
Projects can only be imported at the top level and in the predefined project structure, 
see also The Structure of ESB Projects
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3.11 Export projects
Here you will learn how to export projects and other resources from the repository to the file system.

3.11.1 Using the Export Wizard for files and projects

In the menu, click Project > Export.
The Resource Export Wizard is opened.
Select destination folder.
Click Save.

•

Note
Projects can only be exported if the top project level is selected.
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4 Case Management
With Case Management in X4 Designer, you can model case-related processes including business 
data, case states, and case-related tasks.

Define business data and case states directly in the Business Processes - this way, you do not only 
model the process flow, but also define a process data model at the same time, which allows you to 
model complex processes, e.g. specific approval processes or processes that pass through various 
states.

Define categories, groups and features to model your business data. Business data, such as invoice 
numbers, can be entered directly in the process at runtime and business rules can be defined based 
on them.

Define various case states directly when modeling the Business Processes. The defined states can be 
evaluated or set in the created BPMN diagrams via event elements, decision tables, gateway 
elements or human tasks.

4.1 Implementing processes and workflows
Typically, people can be integrated into Business Processes via tasks. When modelling Business 
Processes, this is done using a Human Task component.

If a Business Process runs on a human task during execution, the execution of the Business Process 
is stopped and the human task is generated. The process waits for the necessary human interaction 
within the Task Management Web App and continues execution as soon as the human task is 
completed.

The following example illustrates the typical implementation with the X4 BPMS.

Model the Business Process as desired.
The example shows a release process in which, depending on the amount of money to be 

With version 7.0 of X4 BPMS, the way processes and workflows are realized with Case 
Management has been changed. When you upgrade from a 6.x to a 7.0 version, existing 
processes are automatically migrated.
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released, either an automatic release or a release by different process participants takes place.

Define the corresponding case states and business data:
To define case states (Case States), please see Managing Case States.

To define business data (Business Data), please see Managing the Business Data 
Structure

.
The data is read via an activity. The activity is linked to a technical process that reads the data 
and outputs all features via the Case Management adapter.
The process state is set via an Intermediate.
The event's property Case State provides all defined case states.
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Decision tables (.rule) are used to store the rules to assign the task to the appropriate person 
depending on the amount. The input specifies where the data to be checked comes from. Via 
Case Feature the previously defined features (see Managing Case States) are specified.

A condition component is used to map the various execution branches. The Condition Editor
allows to use the case states of the currentBusiness Process as evaluation criteria for the 
conditions, see Creating conditions.

Decision tables can also be used to evaluate variables, features, custom placeholders 
or status values (Case State). To do this, Ctrl + space bar in the rule area can be used 
to call up all currently available variables (v:variable name), features (f:feature 
name), custom placeholders (p:placeholder name) and operation status values 
(c:CaseState) in a selection list.
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Configure the corresponding Human Task for each branch and the appearance of the Task 
Management Web App.
Save and execute the process.
Open the Task Management Web App via the menu Tools > X4 Task Management.
Log in to the Task Management Web App.
The tasks to be edited are displayed within the application.

Edit the tasks.

4.2 Managing Case States
To implement cases with X4 BPM, it is required to define a data structure for the business case within 
the Business Process. In domain model files (.domainmodel) you can define business data 
structure in a three-staged hierarchy to the process definition, including descriptions.

4.2.1 Structure of Business Case Data
A case's business data is structured in categories, groups, and features:

Categories group business data on the highest level containing feature groups. Each category 
has a name, a position within the tree and an optional description.
Groups aggregate business data features of the same category. Each group has a name, a 
position within the tree and an optional description.
Features are specific business data properties, e.g. an order date within a feature group. Each 
feature has a name, a position within the tree and an optional description, a data type, and an 
optional default value.

Available data types for features are:

String: String
Integer: Integers
Decimal: Decimals
Boolean: Boolean values
DateTime: Date and time

4.2.2 Defining Business Case Data
Business case data can be defined both for individual business processes and for the entire project or 
several business processes.

Right-click the .bpm file in the Repository Navigator view.
Select New > Domain Model in the context menu.

The rule module evaluates which user is allowed to edit a process.

Which editing functions are available depends on the configuration in the Human Task.
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The file is now created and opened in X4 Designer.

Define the business data structure and its descriptions. 
To create a new feature category, click Add or select  Add > Category. Then enter a 
category name (Name) and a corresponding description (Description).
To define a feature group, click Add when a category is selected or select  Add > 
Group. Then enter a group name (Name) and a corresponding description (Description).
To define a feature, click Add when a group is selected or select  Add > Feature. Then 
enter a feature name (Name), a corresponding description (Description), a data type 
(Type) and a default value for the feature (Default Value). 
Example:

•

•

If the business case data applies to several Business Processes, the 
corresponding .domainmodel file is created within the repository folder Activiti
es > DomainModel.
If the business case data applies only to one specific Business Process, the 
corresponding .domainmodel file is created directly below the Business 
Process. After saving, the .domainmodel file is automatically attached to the Sta
rt component.
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Click the  icon in the toolbar to save.
Drag the .domainmodel file to the desired Business Process.

4.3 Managing Case States
To map processes with X4 BPM, it is necessary to define the required case states of the Business 
Process. Case states and state descriptions are defined in a separate file (.state).

4.3.1 Add case states

Right-click the .bpm file in the Repository Navigator view.

•
•

To change the sequence of a selected structure element, click  or 
The Delete button allows you to remove a selected entry from the tree.



.domainmodel files created below the Business Process are automatically attached to 
the Start component. The business data are therefore available in the process and the 
related Human Tasks.
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Select New > Case States in the context menu.
A new .state file is created and opened.

Click Add to define a new state:
In Name, enter the name of the state, e.g. Approved.
In Description, enter an associated description (optional).

To change the order of a selected state value, click on  or .
Save file.

4.4 Task Management Web App
Human Tasks allow integrating people into Business Processes. The Task Management Web 
App provides the user interface for processing the defined tasks. 

The Task Management Web App already has a predefined structure and predefined functions. 
However, further settings can be made within the corresponding Business Process and via various 
settings within the Human Task Editor.

Use the Delete button to delete a selected state value.

Set case state with intermediate events
You can also set the state of an operation that is to be processed at runtime of the 
current Business Process with Intermediate Events. Therefore, all process-wide defined 
process state values are available for selection in the Case Management > Case State
property of the Intermediate Event.
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4.4.1 Defining and Displaying Business Case Data 
Business case data is defined via the Business Process property Business Data, see Managing Case 
States. Which of the defined business data is actually displayed in the Task Management Web App for 
the user logged in is specified within the Human Task Editor's tab Business Data.

The Task Management Web App can be opened via the menu Tools > X4 Task Management. 
The default access data is demo/demo.
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4.4.2 Defining and Setting Case States
Case states are defined via the Business Process property Case States, see Managing Case 
States. Which of the defined states a user can actually set for his tasks within the Task Management 
Web App is specified within the Human Task Editor's tab Actions. 

4.4.3 Declining, Forwarding and Resubmitting Tasks
Whether a user should be able to decline, forward or resubmit tasks is specified within the Human 
Task Editor's tab Settings, see also Human Task.
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4.4.4 Displaying and Editing Documents
Whether documents can be displayed and processed in the Task Management Web App is 
specified within the Human Task Editor's tab Settings, see also Human Task.

Option Enable Documents displays the tab Dokumente and the button 
Herunterladen (download) within the Task Management Web App.
Option Documents can be added/edited allows editing (button Hochladen) and adding 
(button Neues Dokument) documents.  

4.4.5 Deadline Management for Human Tasks
For each human task a deadline can be defined, which is specified within the Human Task Editor
under General > Deadline. In addition to a duration (Duration), an exact time limit (Until) with a date 
and time specification can be defined. Moreover, a case state can be specified, which is 
automatically executed when the task deadline has been reached.
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If a human task's deadline was reached before it could be processed and the process was 
automatically resumed with the configured case state, the human task is automatically closed and 
displayed within the Task Management web app's navigator node Verfallen (expired). All human tasks 
that have exceeded the deadline and have been closed automatically are displayed here.

In order to better recognize processes with a deadline in the Task Management web app, they are 
highlighted in different colors:
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: The due date of the human task was exceeded and the task was automatically closed and 
moved to the navigator node Verfallen (expired).

: The human task is due on the same day.
: The due date for processing the human task is > 24 hours. 

4.4.6 Editing Tasks in the Task Management Web App
There are various processing options for tasks that have been assigned to a process participant. 
These options are explained in the following.

4.4.6.1 Editing Tasks

After logging in to the Task Management Web App, all open tasks are displayed in an overview (menu 
Offen). By selecting a task in the task list, its details are displayed on several tabs.

The Task Management Web App is currently only available in German. Thus, the following 
editing options are described by means of the German interface. 
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To edit a task proceed as follows:

Select the task to be edited within the task list of the overview (menu Offen).
Click on Bearbeiten.
Select the desired editing option:

Freigeben: Release task
Ablehnen: Decline task
Herunterladen: Download document 
Hochladen: Replace existing document
Dokument löschen: Delete document
Neues Dokument: Upload new document

4.4.6.2 Releasing Tasks

To release a task proceed as follows:

Select the task to be released within the task list of the overview (menu Offen).
Click on Bearbeiten to open the editing view.
Click on Freigeben.
The task is now moved to the menu entry Erledigt.

4.4.6.3 Declining Tasks

To decline a task proceed as follows:

Select the task to be released within the task list of the overview (menu Offen).
Click on Ablehnen.
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The tasks is now sent back to the task owner (Owner).

4.4.6.4 Forwarding Tasks

To forward a task proceed as follows:

Select the task to be forwarded within the task list of the overview (menu Offen).
Click on Weiterleiten.
The following dialog is opened:

Specify the assignment type:
Persönlich: The task will be forwarded to a single user
Team: The task will be forwarded to a group

As an alternative, the task can be declined in the editing view. To do this, first click 
Bearbeiten and then Ablehnen.
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Click on Weiter.
The following dialog is opened:

Specify the forwarding details:
Select the corresponding user or group under Zuweisung 
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If required, define a deadline in Fälligkeitsdatum
To do this, enable the checkbox and select a date and time. Confirm with .

If required, enter a comment in Kommentar.
Click on Weiterleiten.
The task is forwarded to the specified user or group. 

4.4.6.5 Resubmitting Tasks

To resubmit a task proceed as follows:

Select the task to be resubmitted within the task list of the overview (menu Offen).
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Click on Wiedervorlge.
The following dialog is opened:

Enter the desired date and time. Confirm with .
If required, enter a comment in Kommentar.
Click on OK.
The task is now moved to the menu entry Wiedervorlage. 

4.4.6.6 Displaying and Editing Documents

To edit documents attached to a task proceed as follows:

Select the task to be edited within the task list of the overview (menu Offen).

Click on Bearbeiten.

If the task is already being processed, select the corresponding task under the menu 
entry In Bearbeitung. 
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Select the tab Dokumente within the task's detail view.

The different editing options are now displayed as buttons:
Click Herunterladen to download the document. 
Click Hochladen to upload a new document from the file system and replace the existing 
document.
Click Dokument löschen to permanently delete the document.

Deleting a document cannot be undone. Only delete documents if you are sure 
that you no longer need them.
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• Click Neues Dokument to upload a new document. To do this, enter a title in the dialog 
Neues Dokument and select a document from the file system with Hochladen.
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5 Scheduler
The scheduler interface provides an overview of all processes for which a scheduled execution has 
been defined. In addition, the interface also offers the possibility to configure new time-controlled 
executions as well as to edit or delete already existing configurations.

When defining schedules, a differentiation is made between the following execution options:

Startup: Execution of a process at server startup
CRON: Execution of a process according to certain cron patterns

The main functions of the scheduler are:

Overview of existing schedules
Create/edit any number of execution points and intervals per process

5.1 Create scheduler

In the Repository Navigator view, right-click a project.
In the context menu select New> Schedule

.The scheduler is created and opened.

5.2 Execute scheduled processes
The following execution options can be distinguished for the scheduled execution of X4 processes:

Execution of a process at server startup
Execution of a process according to certain cron patterns

•
•

The scheduler can only be created in BPM and ESB projects.
Only one scheduler can be created in a project.



For further information please visit the section
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Cron patterns allow you to execute processes at specific times on specific days, for example, every 
Friday, at 12 noon.

5.2.1 Create new scheduled execution
To create a scheduled execution, proceed as follows:

In the scheduler .schedule click the desired execution option.
Cron to execute processes according to specific cron patterns.
Startup to execute processes at server startup.

Set the desired configuration.

Click Save to save the execution.

5.2.2 Server start
New configurations for executions at server startup can be created using the  Startup button. A 
number of options and parameters are available. These are explained in more detail below.

Options

Name Freely selectable name for execution
Process Path to the process in the X4DB

Example: Processes/Activities/Processes/Process.wrf

Click Browse... to select a process.

Active Activates the scheduler

Start date Sets the start date of the scheduler in jjjj-mm-tt hh:mm:ss format

Example: 2021-06-01 13:00:00

For the configuration options of the different types of execution, see:

For documentation on the ReST interface, see http://localhost:8080/X4/X4Api/.

•
•

The process must be in the same project as the scheduler.
The process must not be a sub-process of another 
process.



http://localhost:8080/X4/X4Api/
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End date Sets the end date of the scheduler in jjjj-mm-tt hh:mm:ss format

Example: 2022-08-01 23:00:00

The end date must be in the future.

Parameters 

In the Parameters section you can define any number of parameters for the run configuration.

Add row

Remove row

Key Name of the parameter (any string, ideally NCName).
Value Optional parameter value

5.2.3 Cron
New configurations for executions at server startup can be created via the Cron button. A number 
of options and parameters are available for this. These are explained in more detail below.

Options

Name Freely selectable name for execution
Process Path to the process in the X4DB

Example: Processes/Activities/Processes/Process.wrf

Click Browse... or drag and drop a process into the field to select a 
process.

Active Activates the scheduler

•
•

The process must be in the same project as the scheduler.
The process must not be a sub-process of another 
process.
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Generate Cron expression Generates a Cron expression

Possible values:

Minutes
Hourly
Daily
Weekly
Monthly
Yearly

Parameters 

In the Parameters section you can define any number of parameters for the run configuration.

Add row

Remove row

Key Name of the parameter (any string, ideally NCName).
Value Optional parameter value

In the Source tab  you can edit the Cron expression manually.

Generating a cron expression is not possible if the cron 
expression was edited manually.





X4 BPM

© SoftProject GmbH 110

1.
2.

•

•

•

•

6 Profiling
In a profiling file (.profiling), you can define whether processes within your project should be 
logged at runtime. In the profiling file, you can define exactly which processes are included or 
excluded from logging.

The pofiling file only needs to be created if you want to exclude specific processes from profiling.  

6.1 Create profiling file

In the Projects view, right-click a project.
Select New > Profiling in the context menu.
The profiling configuration file is created and opened.

6.2 Configure profiling
The root element of the profiling file is <Profiling>. The element can contain individual processes 
of the project that should be explicitly covered or excluded from logging.

The <Profiling> element can have the following attribute:

Attribute Description
active Defines whether logging of processes is enabled or disabled.

Possible values:

true: Logging of the processes is enabled. (default)

false: Logging of the processes is disabled.

The <Profiling> element contains the <Processes> child element, which may contain the following 
attribute:

Attribute Description
filterType Defines whether the stored processes should be included or excluded 

from logging.

Possible values:

include: The stored processes are explicitly covered by the 
logging.

exclude: The stored processes are explicitly excluded from 
logging.

Only one .profiling file can be created in a project.
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The <Processes> element may contain <Process> child elements if one or more processes are to be 
explicitly covered or excluded from logging.

The Process element contains the following attribute:

Attribute Description
path Required. Contains the path to the Technical Process to be captured 

or excluded.

Possible values: Repository path to a Technical Process (e.g. 
Processes/Process.wrf)

6.3 Example of profiling configuration file
In the following example, the Technical Processes Process_B.wrf and Process_C.wrf are excluded 
from logging.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<Profiling>
    <Processes filterType="exclude">
        <Process path="Processes/Process_B.wrf"/>
        <Process path="Processes/Process_C.wrf"/>
    </Processes>
</Profiling>
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