
X4 Data Model





X4 Data Model

Last updated: 28.10.2022 3

The information in this document is subject to change without notice. SoftProject GmbH assumes no 
responsibility for any errors that may appear in this document.

This document may not be copied, photocopied, reproduced, translated or converted to any 
electronic or machine-readable form in whole or in part without prior written approval of SoftProject 
GmbH.

Mentioned products are trademarks or registered trademarks of their respective owners.

Contact
SoftProject GmbH

Am Erlengraben 3

D-76275 Ettlingen – Germany

Website: www.softproject.de 

Sales 
Phone: +49 7243 56175-0 

vertrieb@softproject.de

SoftProject Support 
Phone: +49 7243 56175-333

support@softproject.de

© SoftProject GmbH. All rights reserved.

http://www.softproject.de
mailto:vertrieb@softproject.de
mailto:support@softproject.de


X4 Data Model

© SoftProject GmbH 4

Table of Contents
1 Interface ...................................................................................................................... 6

1.1 Toolbar......................................................................................................................... 6

1.2 Context Menu ............................................................................................................... 8

1.3 Perspectives ................................................................................................................11

1.3.1 Switching perspectives ................................................................................................11

1.3.2 Reseting perspectives..................................................................................................11

1.4 Views ...........................................................................................................................11

1.4.1 Open views.................................................................................................................. 16

2 Working with Data Model Projects ............................................................................... 17

2.1 Creating a Data Model Project...................................................................................... 17

2.2 Creating Entities ......................................................................................................... 18

2.3 Using a Data Model in an ESB Project.......................................................................... 20

2.4 Using a Data Model in an X4 Web App........................................................................... 21



X4 Data Model

© SoftProject GmbH 5

•
•
•
•

About the X4 BPMS

Digitalization requires a holistic approach, which presupposes that also the used solution has to 
reflect that. X4 BPMS supports you as a central platform in solving these challenges. The focus is on 
modeling, implementing and monitoring your business processes. Therefore, the X4 BPMS contains 
all necessary tools and is compatible with a variety of interfaces and formats. That helps to avoid 
isolated information silos and media breaks that inhibit productivity, and accelerate digitization at the 
same time.

Implementing business processes without programming effort enables a large number of users to 
enter into the management of business processes. That's important, since employees of the 
specialist department usually know best what is important in the respective business 
processes. Therefore, you should rely on the X4 BPMS as a platform whose tools reduce complexity to 
such an extent that business processes can be analyzed, optimized, modeled, as well as controlled 
and documented even without programming knowledge. All tools support integrated, graphical 
process modeling and implementation and generate processes that are executed by the X4 BPMS 
with high performance.

X4 Designer: Modelling processes and rules graphically
X4 Server: Simulating and executing processes and rules
X4 Adapter: Integrating third-party systems into processes
X4 Activities: Providing web apps for employees and customers
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1 Interface

1 Menu bar The menu bar allows to open various functions and editors of the 
X4 Designer.

2 Toolbar The toolbar offers different functions and display options. Some 
symbols are only active, if the corresponding function is 
available for the selected or opened element, see also Toolbar.

3 Views Views can be arranged individually via drag-and-drop.
4 Perspectives Switch between X4 Designer and BPMN Designer perspective.

5 Editors and workspace Processes and files are opened here for editing in tabs.
6 Status bar The status bar displays the connected server, the logged-in user 

and the version.

1.1 Toolbar
Various functions and display options can be called up via the toolbar. Some icons are only active if 
the relevant function is available for the selected or opened element.
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Connect Connect to the server

Disconnect Disconnect from the server

New Add new element

 The insert option varies depending on where you are in the 
tree structure in the Repository Navigator.

Save Save changes in the currently opened window

Save all Save all changes

Repository Refresh Perform server-side update

/
Attach/Detach Debug Attach debugger to server instance / Detach debugger from 

server instance

Start Debugging Start Debugger

Undo Undo last editing step

Redo Restore undone step

Cut Cut selection

Copy Copy selection

Paste Paste selection

Start Debugging Call up options for process execution

Start Debugging: debug process (show and fix errors)
Start Without Debugging: Execute process directly
Debug/Run Options: Open Run/Debug settings in X4 
Designer

Suspend Stop debugging process

Resume Continue debugging process

Stop Debugging Terminate debugging
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Step Into Execute process step (display steps of the subprocess)

Step Over Execute process step (without displaying steps of the 
subprocess)

Step Return Jump out of subprocess

Toggle Breakpoint Set or remove breakpoint for marked element

Clear all Breakpoints Delete all breakpoints in this process

Quick Watch Open Quick Watch view to view placeholders, dynamic 
parameters and context variables with their values during 
debugging.

Output Open Output view to view the result of each process step during 
debugging.

Zoom Out Zoom out view

Zoom Select zoom level

Zoom In Zoom view

Snap to grid Display grid and align elements to grid

Show Process Quality Index Display Process Quality Index

1.2 Context Menu
Context menu for process components

When you right-click a process component in the X4 Designer's editor area, you have access to 
different features – depending on the component type and the:
Add Component Add new process component



X4 Data Model

© SoftProject GmbH 9

•

•
•

•

 Layout Align selected process components

Align Horizontal: Align the process components 
horizontally
Align Vertical: Align the process components vertically
Distribute Horizontal: Distribute the process components 
horizontally
Distribute Vertical: Distribute the process components 
vertically

Select All Select all process components
Copy Process Diagram to 
Clipboard

Copy the process diagram

Edit Label... Edit the process component's label
Undo ... Undo the last editor action

Redo ... Redo a previously undone editor action

Copy Copy a selected process action

Cut Cut selected process action

Set ... document Replace a marked process component with another repository 
element

Edit ... Edit a selected process component (module components and 
documents only)

Toggle Breakpoint Set a debug breakpoint for the selected process action

Delete Delete a selected process component from the process diagram

Validate Check the subprocess' validity (subprocesses only)
Preview Open process component in a separate editor tab (Module 

components and documents only)

Show input schema Display input schema assigned to the sub-process, if available
Show output schema Display output schema assigned to the sub-process, if available
Select in Repository 
Navigator

Show process component in the Repository Navigator

View Call Hierarchy Display the processes using the selected process component

Refresh Reload a selected process component from the repository (Module 
components and documents only)

Bring to Front Bring a selected symbol to the foreground of the diagram
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Bring Forward Bring a selected symbol one level up towards foreground

Send Backward Bring a selected symbol one level down towards background

Send to Back Bring a selected symbol to the background of the diagram

Properties Display process component properties in the Properties view

Schema Declaration ... Specify schema declaration for the process

Context menu in the Projects view

You can open the context menu by right-clicking on an element within the Projects view.

New Create new elements (processes, directories, adapters, etc.) in the 
repository

Open / Open with Open the selected element (process, folder, adapter etc.) with the 
default editor or a specific editor

Save As Template Saves the selected element as template

Copy full path to 
Clipboard undCopy XStore 
URL to Clipboard

Copy the path of the selected element to the clipboard (as relative 
folder path or as xstore:// URL)

Cut, Copy and Paste Cut, copy, or pastes the selected element(s)

Delete Delete selected element from the repository (irreversible)
Refactor/Rename Rename an element (and change references, if desired)
Exclude from Project Exclude the resource from the project

Include to Project Include an excluded resource to the project

Repair References Repair incorrect repository resource paths in process diagrams
Validate Check the selected process's validity
View Call Hierarchy Display the processes that use the selected elements
Start Without Debugging Run process directly
Import Import resource to the repository
Export Export project or resource
Clean-Up Project Select and delete unused files from the repository

•

•

The file will remain in the file system, but is no longer part 
of the project and is grayed out.
The usual operations such as opening, editing, copying, 
deleting, etc. of excluded files are disabled.


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1.3 Perspectives
A perspective is a defined arrangement of views and the editor area. The arrangement of the views 
can be defined by drag-and-drop.

X4 Designer The X4 Designer perspective is the default perspective.

Debug The Debug perspective is an optimized perspective to debug business and technical 
processes.

BPMN 
Designer

The BPMN Designer perspective is an optimized perspective to model business 
processes.

1.3.1 Switching perspectives
In X4 Designer, you can switch between perspectives. The arrangement of the views is kept.

To change the perspective, click on the icon of the desired perspective in the upper right 
corner.

1.3.2 Reseting perspectives

To reset a perspective, switch to the perspective.
Select Window > Reset Window Layout in the menu bar.

1.4 Views
Projects The Projects view displays a tree structure of the connected repository with various 

elements such as projects, folders and files. The context menu can be opened by 
right-clicking on an element in the Projects view. The available options change 
depending on where in the tree structure the context menu is called.

The Filter text field above the project tree can be used to search for files within the 
connected repository. Placeholder like * or ? are not possible.

The following actions can be performed using various buttons:

 Jump from active Editor to Repository Navigator: Highlight opened file in the 
editor within the Repository Navigator.

 Show or hide all files: Show and hide contents of the file system. Files 
excluded from the project are grayed out.

Apps The Apps view displays all X4 Apps that are used to bundle projects.
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Properties In the Properties view, the properties of selected process modules and of opened 
processes can be displayed and edited:

The left column displays the property name, the right column contains 
the corresponding values.
A title and a description can be stored for each process. These are displayed in 
the generated documentation.
To edit properties of an opened process, click on an empty area on the workplace.

The most common properties are displayed by default, however, additional settings 
can be made using the Properties view toolbar:

 Pin to Selection: Pin displayed properties in the Properties view

 Show Categories: Show properties sorted by categories

 Show Advanced Properties: Show advanced properties

  Restore Default Value: Restore to default value

View Menu: Open additional options

Run/Debug 
Console

If a process is checked for errors or simulated, debug information is displayed in the 
Run/Debug Console view for each executed process step. Error messages are 
highlighted in red, successful status messages are green.

When a process step outputs an intermediate result, it is stored in a temporary file 
during debugging, which you can view using the corresponding reference (e. g. file:
//1376054979039/). 

The Run/Debug Console view can be accessed from the View > Run/Debug 
Console menu.

file://1376054979039/
file://1376054979039/
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Output The Output view allows to view the intermediate results of each debug step.

The following additional actions can be performed via the toolbar:

Find content: Find data in the Output view

Copy all content: Copy all data from the Output view to the clipboard
Copy selected content: Copy selected data from the Output view to the 

clipboard

 Save content of output view: Save the data form the output view

 Format the content of the output view: Format the data form the output view

The Output view can be opened during debugging via the menu Debug > Output or 
using the Output icon  in the toolbar.

If the result of the debug step contains content greater than 1 MB, a warning 
is displayed and the result can be downloaded via a button.
Large amounts of data can affect the performance of the X4 Designer. 


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X4 Server 
Log

The X4 server log view allows to track the server status and especially errors in the 
X4 Server log from within the X4 Designer.

 The Server Log view can be accessed via the View > X4 Server Log menu.

Call 
Hierarchy

The Call Hierarchy view allows to display all repository elements using a certain 
process or process component in the repository.

Right-click on the desired element in the Repository Navigator to bring up a context 
menu. View Call Hierarchy then displays a list of all repository items that contain at 
least one reference to the selected item.
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Error Log The Error Log view allows to view errors that occurred in the X4 Designer.

The following additional actions can be performed via the toolbar:

 Export Log: Export Error Log and save it as .log file
 Import Log: Import Error Log (.log)
 Clear Log Viewer: Clear Error Log 
 Delete Log: Delete Error Log permanently
 Open Log: Open log file (.log) in X4 Designer
 Restore Log: Restore Error Log
View Menu: Open additional options

 The Error Log can be opened via the menu View > Error Log.

Problems In the Problems view, all errors and warnings are listed. The filter can be used to 
customize the displayed list.

Debug 
sessions

The Debug sessions view lists all active debug sessions. In the Debug sessions view, 
double-click the desired process to switch to the debug session.

Active debug sessions are marked in gray. New debug sessions connected to the 
server are highlighted in orange.

Breakpoint
s

In the Breakpoints view, all set breakpoints are listed. In the Breakpoints view, 
breakpoints can be activated, deactivated and deleted. Additionally, all breakpoints 
can be skipped without deleting the breakpoints.
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Quick 
Watch

In the Quick Watch view, placeholders, dynamic parameters and context variables 
can be viewed with their values during debugging.

Selected variables are updated after each debug step.

The Quick Watch view can be accessed during debugging via the Debug > Quick 
Watch menu or via the Quick Watch icon in the toolbar.

Outline In the Outline view, the complete process diagram is displayed as an image. By 
clicking on the individual areas of the illustration, it is easy to navigate through the 
process, even if it is larger than the size of the Designer window.

 The Outline view can be opened via the menu View > Outline.

Base64 Base64 encode or decode strings

Digest Generate hash value for strings

Regex Apply regular expression (Regex) to a string to test the expression or to directly 
replace the string according to a pattern

URLCodec URL encode or decode strings

1.4.1 Open views

Select the desired view from the View menu in the menu bar.

If the result of the debug step contains content greater than 1 MB, a warning 
is displayed and the result can be downloaded via a button. 
Large amounts of data can affect the performance of the X4 Designer. 



No other views can be opened in the BPMN Designer perspective, all relevant views are open 
by default.


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2 Working with Data Model Projects
Using the Data Model Project project type you can define complex data models and integrate them in 
ESB processes and X4 Web Apps. You can represent complex data structures in a Data Model Project, 
such as a purchase order with addresses and items you re-use in other locations. The major 
advantage of this approach is the ability to re-use data models, e.g. in web apps, without having to 
define them multiple times. 

2.1 Creating a Data Model Project
To create a new Data Model Project:

In the X4 Designer, right-click in the Projects view and choose New from the context menu. 
Choose Data Model Project....

Enter a name for your project in the Project Creation Wizard dialog.
Choose Finish.

Data Model Projects have a predefined folder structure which is automatically created when you 
create a new Data Model Project. 

Entities This folder is empty when creating a project. You can add 1 to n entitys.

<Project>.dat
amodel

Project-related file containing the data model definition. You set the relationships 
between the entitys in this file.

When creating a new Data Model Project the <Project>.datamodel file looks as follows:

<?xml version="1.0" encoding="UTF-8"?>
<DataModel xmlns="http://softproject.de/datamodel/1.0">
    <EntityRelationships>
    </EntityRelationships>
</DataModel>

The EntityRelationships element is used to set the relationships between the entities created by 
you which are represented in the data model. Any relationship you specify will result in a hierarchy. 
For more information on creating entities, see the Creating entities section.

The EntityRelationships element can contain the following elements:

OneToOne

Alternatively, you can click on New in the File menu and select Data Model Project....

The Entities folder cannot be deleted, moved, or renamed.
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OneToMany
ManytoOne

These three elements provide of the following attributes for the definition of the relationships 
between the entities:

Attribute Description
entity You can use this attribute to specify the from entity of the 

relationship.
toEntity You can use this attribute to specify the target entity of the 

relationship.
property You can use this attribute to specify the name which is used to 

reference the entity specified in toEntity for  the entity with 
respect to the further usage of the data model.

You can, for example, specify a delivery address as the property for a 
one-to-one relationship between a customer and an address, as 
shown in the following example.

Example:

<DataModel xmlns="http://softproject.de/datamodel/1.0">
    <EntityRelationships>
    <OneToOne entity="Customer.entity" toEntity="Address.entity" 
property="DeliveryAddress"/>
    <OneToMany entity="Customer.entity" toEntity="Order.entity" property="Order"/>
    <ManyToOne entity="Order.entity" toEntity="Customer.entity" property="Customer"/>
    </EntityRelationships>
</DataModel>

2.2 Creating Entities
Each entity corresponds to an object in your application, e.g. "order" or "customer". The relationship 
between two or more entities is represented via associations. Each entity (object) contains fields 
(properties) and is labeled with a unique technical ID field which is needed for associations.

To create a new entity:

Right-click on the Entities folder.
Choose New > Entity.
Enter an entity name in the File Creation Wizard dialog. 
Choose Finish.

In the next step, you can add properties to your entity. To do so, double-click on the .entity file in 
the Projects view to open it in the Entity Editor.

Choose Add to add the desired properties, e.g. name or id:
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The table in the .entity file contains the following fields:

Field Description
Name You enter the desired name for your property in this field.

Use the Add button to add a new property.

Use the Remove button to remove properties you do not need anymore.

Type You use this drop-down to set the type of the property.

Possible values:

STRING
INTEGER
DECIMAL
BOOLEAN
DATE
DATETIME

Is ID Use this checkbox to define whether the property is a defined ID.
Mandat
ory

Use this checkbox to define whether the property is mandatory or optional.

Read 
only

Use this checkbox to define whether the property is read-only.

You can sort the entries by selecting an entry and move it up or down using the arrows on the 
top right. This way you can arrange the entries as desired.


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2.3 Using a Data Model in an ESB Project
To use a data model in an ESB Project:

Create a new ESB project or open an existing ESB project. 
Right-click on the Transformations folder and choose New > XSL Stylesheet.
Choose Empty in the File Creation Wizard to create an empty transformation.
Enter a name for the mapping file and choose Finish.
Move the .datamodel file via drag-and-drop from the Data Model Project into the empty space 
on the left side of your mapping side.
The Select Entities dialog is opened where you select which entities from your data model are 
to be included in the mapping file.

The dialog box contains the following options for the example shown in the Creating a Data 
Model Project section in which the Customer, Address, and Order entities with different 
relationships were created:

Once the structure has been generated and is displayed you can start with the mapping. For 
more information see Mapping.

In addition to the Design view shown above you can also open the .entity file in the 
Source view and define the properties as XML elements and the corresponding attributes.


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2.4 Using a Data Model in an X4 Web App
To use a data model in an X4 Web App:

Create a new Web App Project or open an existing Web App Project.
Right-click on the ViewModels folder and choose New > View Model....
Enter a view model name in the File Creation Wizard dialog and choose Finish.
Move the .datamodel file via drag-and-drop from the Data Model Project into Properties ele
ment in the .viewmodel file.
The Select Entities dialog is opened where you select which entities from your data model are 
to be referenced in the .viewmodel file.

The entities and their properties are referenced in the .viewmodelfile. You can edit the 
properties with additional attributes (displayName, readOnly).

Example:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ViewModel xmlns="http://softproject.de/viewmodel/1.0">
    <Properties>
        <Model path="Demo/Entities/Customer.entity">
            <ModelProperty name="Name" displayName="Name" readOnly="false"/>
            <ModelProperty name="Firstname" readOnly="false"/>
            <ModelObject name="DeliveryAddress" path="Demo/Entities/Address.entity">
                <ModelProperty name="City" readOnly="false"/>
                <ModelProperty name="Zip" readOnly="false"/>
                <ModelProperty name="Street" readOnly="false"/>
            </ModelObject>
            <ModelList name="Order" path="Demo/Entities/Order.entity">
                <ModelProperty name="Product" readOnly="false"/>
                <ModelProperty name="Quantity" readOnly="false"/>
                <ModelObject name="Customer" path="Demo/Entities/Customer.entity">
                    <ModelProperty name="Name" readOnly="false"/>
                    <ModelProperty name="Firstname" readOnly="false"/>
                    <ModelObject name="DeliveryAddress" path="Demo/Entities/
Address.entity">
                        <ModelProperty name="City" readOnly="false"/>
                        <ModelProperty name="Zip" readOnly="false"/>
                        <ModelProperty name="Street" readOnly="false"/>
                    </ModelObject>
                </ModelObject>
            </ModelList>
        </Model>
    </Properties>
</ViewModel>

Example for embedding a .viewmodel file in a component:
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<?xml version="1.0" encoding="UTF-8"?>
<DetailComponent xmlns="http://softproject.de/webapp/1.0" 
viewmodel="ViewModel.viewmodel">
<Properties>
</Properties>
<FlowLayout>
<Header value="Welcome to my new Web App!" />
<TextBox value="#Customer.Name" />
</FlowLayout>
</DetailComponent>
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